Issues getting DotNetNuke Data Provider for MySql running

Issues getting DotNetNuke Data Provider for MySql running

Postby rlm1115 » Thu 09 Feb 2012 13:29

I have done the following on Windows 7 Pro SP1 w/ IIS 7.5:

1) downloaded and successfully installed DotNetNuke version 6.01.03
2) downloaded and successfully installed dotConnect for MySql Standard Edition trial (version downloaded Wed, Feb, 8 )
3) downloaded DotNetNuke Data Provider for MySql (latest version off your website yesterday)
4) copied the files from the mysqldnn.zip into the root of the DotNetNuke install on the web server per instructions.
5a) Modified the config file supplied in the zip per instructions (connectstring and assembly info) and renamed to web.config. Didn't work
5b) Took the DotNetNuke web.config and modified it with the differences from the Devart zip supplied config. Didn't work.

Where I am right now is with the config from 5b generating the following:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
DotNetNuke.Common.Globals.get_Status() +104
DotNetNuke.Services.Log.EventLog.LogController.AddLog(LogInfo logInfo) +48
DotNetNuke.Services.Log.EventLog.ExceptionLogController.AddLog(Exception objException, ExceptionLogType LogType) +3097
DotNetNuke.ComponentModel.ProviderInstaller.InstallProvider(IContainer container, Provider provider) +257
DotNetNuke.ComponentModel.ProviderInstaller.InstallComponents(IContainer container) +184
DotNetNuke.ComponentModel.ComponentFactory.InstallComponents(IComponentInstaller[] installers) +118
DotNetNuke.Common.DotNetNukeHttpApplication.Application_Start(Object Sender, EventArgs E) +284

[HttpException (0x80004005): Object reference not set to an instance of an object.]
System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +4185553
System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +205
System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +336
System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +350
System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +382

[HttpException (0x80004005): Object reference not set to an instance of an object.]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11335894
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88
System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4355316

Obviously there is something not defined but I have no idea where to look. I have compared the two config files (dnn supplied web.config and Devart supplied DevartMySql-DNN-4.7.0.0.config and the only differences are the connection strings and the assembly information. Any clue what I am doing wrong?

I really need to move forward quickly to see if this is going to work for my desired web-based application on the trial Standard Edition license.

Thanks in advance,
Rusty

Update: Below is what I am getting with 5a above:

HTTP Error 500.22 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Most Likely Causes:
This application defines configuration in the system.web/httpModules section.

Things you can try:
Migrate the configuration to the system.webServer/modules section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using AppCmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.
If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
Alternatively, switch the application to a Classic mode application pool - for example, %SystemRoot%\system32\inetsrv\appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.

(Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

Since I didn't install DotNetNuke under the 'Default Web Site', I don't know where to go from here.

Rusty
rlm1115
 
Posts: 1
Joined: Thu 09 Feb 2012 12:27

Postby Shalex » Mon 13 Feb 2012 10:25

Please refer to http://www.devart.com/dotconnect/mysql/ ... tNuke.html . So, you can use the latest version of dotConnect for MySQL, but we recommend using DotNetNuke of the 4.7.0.0 version because our provider was tested with it. We can send DotNetNuke_04.07.00_Source to you if you need (let us know).

We will investigate the possibility of supporting the latest versions of DotNetNuke and notify you about the results as soon as possible.
Shalex
Devart Team
 
Posts: 7774
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL