Upgrade from 4.30 to 6.60 - need some help

Upgrade from 4.30 to 6.60 - need some help

Postby islandhopper8 » Sun 15 Jan 2012 16:56

I just upgrade from 4.30 to 6.60 and I have some issues.

I VS2008 I don't see the MY Database Icon in the "Data Source Configuration Wizard" However it does show in VS2010.

Futhermore in VS2010 I don't see the menu option configure data source under the Gridview Tasks.
Also when I am want to change the MySqlDataSource and select "configure Data Source" the wizard does not show up anymore.

Second issue I am experiencing is that when I am trying to connect from the local machine to a remote database the authentication will not work, it gives me an authentication error. However on the deployed website the membership works fine and I am able to login.
islandhopper8
 
Posts: 3
Joined: Sun 09 Nov 2008 02:48

Postby Pinturiccio » Wed 18 Jan 2012 11:06

islandhopper8 wrote:I VS2008 I don't see the MY Database Icon in the "Data Source Configuration Wizard" However it does show in VS2010.

When I install dotConnect for MySQL and run Visual Studio 2008, I do not have 'MY Database' Icon too. But when you run Visual Studio first time after the installation, Visual Studio packages are merged, components are added to the Toolbox, etc. After some time passed the dotConnect for MySQL components appear in the Toolbox and 'MY Database' Icon appears in "Data Source Configuration Wizard" too. In Visual Studio 2010 these processes are performed faster, and when I create GridView the 'MY Database' Icon already exists.
islandhopper8 wrote:Futhermore in VS2010 I don't see the menu option configure data source under the Gridview Tasks.
Also when I am want to change the MySqlDataSource and select "configure Data Source" the wizard does not show up anymore.

There is no 'Configure Data Source' menu item for the Gridview Tasks. When you create some DataSource in Visual Studio 2008/2010, a new MySqlDataSource component named MySqlDataSource1 appears. You can invoke 'Configure Data Source' wizard for this component but not for the Gridview Tasks.
islandhopper8 wrote:Second issue I am experiencing is that when I am trying to connect from the local machine to a remote database the authentication will not work, it gives me an authentication error.

Could you please describe 'authentication error' in more detail:
1. The text and call stack of the 'authentication error';
2. Screenshot of the 'authentication error';
3. A small test project will be appreciated.
Pinturiccio
Devart Team
 
Posts: 2021
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for MySQL