4.1 problem

4.1 problem

Postby kgoodrich » Wed 01 Dec 2004 22:23

Can someone please help me. I recently upgraded my mysql server from 4.0 to 4.1.7. I am and have been using mysqldirect.net 1.8 with no problems. Since I have upgraded, my applications using mysqldirect.net cannot connect. I keep getting the following error:

Client does not support authentication protocol requested by server; consider upgrading MySQL client

I have tried putting in the old-passwords directive in my.ini. I have entered it every way possible, but my old-passwords variable never changes from OFF. What is the deal, does MySqlDirect.NET 1.8 not support the new password format presented by mysql 4.1.7??????????????????

Help me,
Thanks,
Kendal
kgoodrich
 

Re: 4.1 problem

Postby Oleg » Thu 02 Dec 2004 12:55

MySQLDirect .NET 1.80 supports MySQL 4.1.0 but doesn't support 4.1.1 as these versions have a lot differences in protocol and API.
This support was added to MySQLDirect .NET 2.0, see History:
- MySQL 4.1.1 alpha support added
Oleg
Devart Team
 
Posts: 264
Joined: Thu 28 Oct 2004 13:56


Return to dotConnect for MySQL