Mono 2.6.7/ASP.NET

Mono 2.6.7/ASP.NET

Postby jmace » Thu 23 Jun 2011 17:44

I have a class library that my web application uses for all of its data manipulation and business rules.

I have referenced:
Code: Select all
DLL         Version      Runtime Version      Location
Devart.Data      5.0.265      2.0.50727      GAC
Devart.Data.Linq   2.50.24      2.0.50727      Local
Devart.Data.MySql   6.30.165   2.0.50727      GAC
Devart.Data.MySql.Linq   2.50.24      2.0.50727      Local

Sorry for the formatting

Anytime I try to execute a query I received the following from xsp2:
Code: Select all
xsp2
Listening on address: 0.0.0.0
Root directory: D:\Users\Jim Mace\Documents\Projects\ShortMags\ShortMags.Web
Listening on port: 8080 (non-secure)
Hit Return to stop the server.

** (C:\PROGRA~2\MONO-2~1.7\lib\mono\2.0\winhack\xsp2.exe:1224): WARNING **: The
following assembly referenced from D:\Users\JIMMAC~1\AppData\Local\Temp\Jim Mace
-temp-aspnet-0\a8f850f0\assembly\shadow\fd2e821f\c5939176_38bd1369_00000001\Shor
tMags.Library.dll could not be loaded:
     Assembly:   Devart.Data.Linq    (assemblyref_index=2)
     Version:    2.50.24.0
     Public Key: 09af7300eec23701
System error: No error


** (C:\PROGRA~2\MONO-2~1.7\lib\mono\2.0\winhack\xsp2.exe:1224): WARNING **: Coul
d not load file or assembly 'Devart.Data.Linq, Version=2.50.24.0, Culture=neutra
l, PublicKeyToken=09af7300eec23701' or one of its dependencies.

** (C:\PROGRA~2\MONO-2~1.7\lib\mono\2.0\winhack\xsp2.exe:1224): WARNING **: The
class <>c__DisplayClass0 could not be loaded, used in ShortMags.Library, Version
=1.0.4191.16577, Culture=en-us, PublicKeyToken=null


I really like this product, but I really need to get it running on Linux using Mono. Any ideas would be greatly appreciated.[/code]
jmace
 
Posts: 2
Joined: Thu 23 Jun 2011 17:17

Postby jmace » Fri 24 Jun 2011 15:33

I still receive the same error if I:
    1.)Drop all of my Class Library Devart.*references
    2.)Copy the necessary Devart.* DLLs into the /bin directory
    3.)Re-create the Devart.* references
    4.)Run the application using xsp2 (Mono 2.6.7)


Do I need to reference another Devart DLL?

Any help would be greatly appreciated,
Jim
jmace
 
Posts: 2
Joined: Thu 23 Jun 2011 17:17

Postby StanislavK » Fri 24 Jun 2011 16:01

I've sent you a test project in a letter, please check that it was not blocked by your mail filter. Before running the sample, please perform the following:
- ensure that the Devart.Data and Devart.Data.MySql assemblies are installed into the GAC;
- copy the Devart.Data.Linq and Devart.Data.MySql.Linq assemblies to the root folder of the LcLibrary project;
- the sample uses LinqConnect 2.50.25, please ensure that you either use the assemblies from the latest build or change the references so that they point to the proper assembly versions.

Please specify whether you encounter the problem with this sample. If no, please specify what should be changed in the test project to reproduce the issue, or send us your sample.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for MySQL