License (Deployment) hell

License (Deployment) hell

Postby yhersh » Sat 07 May 2011 14:46

Hi,

I want to be able to deploy my application without the setup installation.

I read everything and used the auto license generator everything is in place but i still get error 0004: Could not load file or assembly 'Devart.Data.MySql.Entity, Version=6.10.141.0

I think you really should reconsider your licensing model !

I am using lightspeed in different project and the the deployment is easy as just copying the dll into the bin folder

This is a show stopper for me

Thanks
yhersh
 
Posts: 22
Joined: Fri 30 Apr 2010 12:13

Postby AndreyR » Wed 11 May 2011 13:04

This error states that you have not placed Devart.Data.MySql.Entity.dll to the Bin folder of your application.
Please make sure that you have deployed the assembly for the corresponding .NET Framework version, this can be the reason of the error as well.
If this advice isn't helpful, please describe all steps you have performed, hope we will be able to find the reason.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby yhersh » Wed 11 May 2011 21:10

Hi,

The file was copied to the bin folder and its a compiled web app.

Even when i used the installer in min. installation was not good enough just after using the full installation mode the app started to work.

I have added references to all possible projects and created lic. files as asked.
yhersh
 
Posts: 22
Joined: Fri 30 Apr 2010 12:13

Postby AndreyR » Thu 12 May 2011 13:59

Glad to hear the issue is resolved.
The most likely reason is the fact that you have deployed the Devart.Data.Oracle.Entity.dll for a wrong .NET version.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16


Return to dotConnect for MySQL