lost connection to mysql

lost connection to mysql

Postby KW » Tue 04 Jan 2011 04:02

I just upgraded to mysql 5.5 and and I am experiencing a problem with mysql and the error "lost connection to mysql server"

I have set every timeout to a more than appropriate number:

connect_timeout = 5000
interactive_timeout = 5000
net_read_timeout = 500
net_write_timeout = 500
wait_timeout = 500

I have also tried using the following connection parameters:

Connection Timeout and default command timeout

The query terminates at 30.5 seconds give or take .5 seconds. Any help or recommendations greatly appreciated.
KW
 
Posts: 119
Joined: Tue 19 Feb 2008 19:12

Postby StanislavK » Tue 04 Jan 2011 18:01

Please specify the values you've set to the 'Connection Timeout' and 'Default Command Timeout' connection string parameters. Also, could you please describe the query and how you are executing it?

If you are executing the query in such a way that the connection should be implicitly open (e.g., calling the MySqlDataTable.Fill method), please also try disabling the connection pooling (i.e., setting the Pooling parameter to false). Please tell us if the problem can be reproduced in this case.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48

Postby KW » Tue 04 Jan 2011 19:58

StanislavK wrote:Please specify the values you've set to the 'Connection Timeout' and 'Default Command Timeout' connection string parameters. Also, could you please describe the query and how you are executing it?

If you are executing the query in such a way that the connection should be implicitly open (e.g., calling the MySqlDataTable.Fill method), please also try disabling the connection pooling (i.e., setting the Pooling parameter to false). Please tell us if the problem can be reproduced in this case.


Damn it!

I apologize, I did set all these server parameters correctly but I didn't set the default command timeout like I thought I had on the connection string and this is giving me back a correct behavior.

default command timeout=20000

Sorry about this post but for other that are recieving this error recheck all of your settings :P
KW
 
Posts: 119
Joined: Tue 19 Feb 2008 19:12


Return to dotConnect for MySQL