SSL problem when database user requires X509

Postby sumit » Wed 20 Oct 2010 16:33

Shalex wrote:Actually, the mentioned fix is included to the 5.80.170 build (it is with the IIS fix and with the Windows 7 problem). It is available for download.


I don't understand. We have tested with version 5.80.170 and found the same problem. Are you saying that you have fixed the code and created another distributable with the same version or that 5.80.170 that we already have should have this fix?
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Thu 21 Oct 2010 16:58

1. Can you reproduce the problem with 5.80.180 as well?
2. If yes, please tell us the exact text of the error and specify your environment (the versions of OS and IIS).
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Thu 21 Oct 2010 17:00

Do you have a time frame for fixing the Windows 7 problem that you mentioned? Once you make that fix available, I will test all the scenarios again with that version and report the results. It is not that easy and cost effective for us to try the test cases again.

Thanks.
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Fri 22 Oct 2010 10:55

Our SSL support implementation is based on standard Windows' CryptoAPI. We cannot tell you for sure if there will be a fix for Windows 7. We will investigate the issue and notify you about the results in 2-3 weeks.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Fri 22 Oct 2010 19:01

Thanks for the update.

Can you tell us about the exact nature of the issues that you have discovered on Windows 7 so that we can analyze if it impacts us?

Also are you implying that the Windows CryptoAPIs themselves are broken on Windows 7? I would assume that if the drivers are using standard windows API, they should work just like any other application. Right?
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Mon 25 Oct 2010 14:30

We will notify you about the results of our investigation as soon as possible.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Fri 12 Nov 2010 16:01

Hi Shalex,

Just wondering if there is any more information?
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Mon 15 Nov 2010 17:40

Hello sumit,

We have fixed the problem. I have opened the SSL connection via IIS 7.5 on Windows 7 x64 successfully. Please try the 6.0.46 Beta version of dotConnect for MySQL on your side and notify us about the results.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Tue 16 Nov 2010 19:25

Thanks for the fix.

Any timelines on when this version will be out of beta and released? We are currently working with tight schedules and won't be able to test this beta release.
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Wed 17 Nov 2010 13:35

We are planning to release dotConnect for MySQL v 6.0 in a week. If you are in a hurry, please use the 5.80.190 version of dotConnect for MySQL - it also includes the fix for Windows 7.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Wed 17 Nov 2010 18:39

Thanks. We should be able to wait for about a week to upgrade to the latest 6.0 version.
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Wed 01 Dec 2010 12:32

New version of dotConnect for MySQL 6.00 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/mysql/download.html (trial version) or from Registered Users' Area (for users with valid subscription only).
For more information, please refer to http://www.devart.com/forums/viewtopic.php?t=19623 .
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Mon 06 Dec 2010 21:12

Thanks for the information but for some reason the only choice that I see for download is for version 5.80.190 when I login to secure.devart.com
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Shalex » Tue 07 Dec 2010 08:39

Please contact our sales department (sales at devart.com) and provide your license number to get credentials to download dotConnect for MySQL v 6.0.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

Postby sumit » Wed 08 Dec 2010 18:44

Hi Shalex,

I sent an email two days ago with our license information and have not received a response. We need to get this version as soon as we can so that we can at least start testing it. Thanks for your help so far!
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

PreviousNext

Return to dotConnect for MySQL