Membership Provider not working, can't load devart reference

Membership Provider not working, can't load devart reference

Postby michaelm001 » Mon 10 May 2010 04:20

I'm evaluating the Devart dotConnect product for MySQL and I've ran across a problem that I can't seem to fix:

General description:

I have installed the Devart dotConnect for MySQL. I am able to make the entity framework functionality work with no problems.

However, I'm encountering problems when I try to use the membership provider in a simple MVC 2.0 website. I change the web.config file as specified here:

http://www.devart.com/dotconnect/mysql/ ... iders.html

But when I go to the login page of the MVC app, I get this error:

Could not load type 'Devart.Data.MySql.Web.Providers.MySqlMembershipProvider'

I have added every single devart reference to the MVC project...so I'm not sure what I'm missing here.

Environment:

Windows 7 64 bit
Visual Studio 2010
Latest Devart dotConnect for MySQL

Thanks for any help you can provide.

-Mike
michaelm001
 
Posts: 1
Joined: Fri 30 Apr 2010 04:38

Postby Shalex » Thu 13 May 2010 13:47

The Devart.Data.MySql.Web.Providers.MySqlMembershipProvider class is defined in the Devart.Data.MySql.Web.dll assembly. Please make sure that this assembly is loaded to the process of your application (in the Debug mode: the Debug -> Windows -> Modules menu of Visual Studio).

If this doesn't help, please tell the exact version (x.xx.xx) of dotConnect for MySQL you are working with (the Tools -> MySQL -> About menu of Visual Studio).
Shalex
Devart Team
 
Posts: 7377
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL