upgrade trial dotConnect for MySQL 5.70.124 problem

upgrade trial dotConnect for MySQL 5.70.124 problem

Postby tragedian » Fri 23 Apr 2010 18:09

I today have tried to upgrade the doConnect for MySQL from 5.70.102 to 5.70.124. During the uninstall process, the setup program failed to remove the toolbox tab. But it still moving on..... At the end of the installation, there are 2 more error boxes came out:

1. During installing assemblies into Global Assembly Cache:
"CrGaUtil.4.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application."

2. During Registering provider configuration in machine.config:
"ProviderConfig.4.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application.

I started the visual studio and have found that there no longer have choice to select MySQL as data provider :shock: ... how can i fix it??
tragedian
 
Posts: 2
Joined: Fri 23 Apr 2010 17:54

Postby tragedian » Sun 25 Apr 2010 13:47

Today I found that the problem only exist for .Net framework 4.0... After upgrading the software, the following section inside machine.config is missing:


description="Devart dotConnect for MySQL" type="Devart.Data.MySql.MySqlProviderFactory, Devart.Data.MySql, Version=5.70.124.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />


Thanks.
tragedian
 
Posts: 2
Joined: Fri 23 Apr 2010 17:54

Postby StanislavK » Mon 26 Apr 2010 11:26

Please specify the exact version of .NET Framework that is installed on your machine. Is it 4.0.30128 (.NET Framework v4 RC)? If yes, the problem is caused by the fact that the 5.70.124 build of dotConnect for MySQL is compatible with .NET Framework v4 RTM only. You may either update Visual Studio and .NET Framework to RTM or use dotConnect for MySQL 5.70.120 which is compatible with Release Candidates.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for MySQL