How to change dotConnect default client encoding

How to change dotConnect default client encoding

Postby multimediapress » Thu 26 Nov 2009 17:21

Hi,

I have dotConnect 5.40.44.
I have a MySql 5.0.51a (Debian linux) server with all encoding setting variables set to utf8.

I connect against a database having some foreign characters in field names on certain tables.

It seems that by default, dotConnect uses a latin1 encoding as a client because the field names appear with the usual "strange" Äx kind of characters.

In fact, if I use "character set=utf8" in the connexion string, it solves the problem.

However I have 2 issues on that:

- Your doc states that I can use the "character set" option in the connexion string but that I'd better "synchronize client and server encoding". My question is: How do I do that? I connot find a client configuration file that allows me to tell dotConnect to use utf8 by default.

- I use a third party OR/M software, namely LLBGen Pro, that uses dotConnect driver but doesn't allow me to customize the conection string. So I'm stuck with my bad field names. What can I do?


here is an excerpt from my MySql server conf:

character set client utf8
character set connection utf8
character set database utf8
character set filesystem binary
character set results utf8
character set server utf8
character set system utf8
character sets dir /usr/share/mysql/charsets/
collation connection utf8_unicode_ci
(Valeur globale) utf8_general_ci
collation database utf8_general_ci
collation server utf8_general_ci

Regards.
multimediapress
 
Posts: 2
Joined: Thu 26 Nov 2009 16:20

Postby Shalex » Fri 27 Nov 2009 10:29

Synchronization of client and server encoding could be made by setting the Charset property of the MySqlConnection object (or the character set option in the connection string) to 'auto'. In this case, the server asks for the charset and sets the appropriate charset on the client.

We recommend you either to contact the LLBLGen team to allow access to the character set parameter of the connection string, or try our ORM tool.
Shalex
Devart Team
 
Posts: 7654
Joined: Thu 14 Aug 2008 12:44

re:

Postby mackkaif » Mon 07 Dec 2009 02:54

thanks for postings :)
mackkaif
 
Posts: 3
Joined: Mon 30 Nov 2009 14:29

Re: re:

Postby multimediapress » Mon 07 Dec 2009 09:41

mackkaif wrote:thanks for postings :)

You welcome.
LLBLGenPro updated its driver so that I can set the Unicode parameter to true.
I cannot use your ORM tool because I have to support MS Access as well.

Regards.
multimediapress
 
Posts: 2
Joined: Thu 26 Nov 2009 16:20


Return to dotConnect for MySQL