Unable to find the requested .Net Framework Data Provider

Unable to find the requested .Net Framework Data Provider

Postby Twixies » Tue 17 Nov 2009 08:29

I have download a trial of the connecter :D
I have this error, and of cause the hosting company running in medium trust and don't have the connector installed.
I have been working with this in 2 days now, and my hair
is getting more and more gray.

error:
Unable to find the requested .Net Framework Data Provider. It may not be installed. on the remote host server. :cry:

I have devart.data.dll, Devart.Data.MySql.dll, Devart.Data.MySql.Web.dll , App_Licenses.dll, Telerik.Web.UI.dll in the bin folder, addding reference to them in the bin folder , compiled and oploaded the files.
I have been trying to make connection in codebehind and i web.config. everytime the same error.


I have search alot arond the internet, and can't find a solution.

I have got the permission from the hosting company and they say i have the follow settings on the server

UnmanagedCode flag is added to the SecurityPermission section.


UnmanagedCode flag in SecurityPermission section.
(
and SocketPermission ()

What am i doing wrong???

Please provide me a sample code (vb)
Regards
Twixies, maybe become as new customer :wink:
Twixies
 
Posts: 2
Joined: Tue 17 Nov 2009 08:10

Postby Shalex » Tue 17 Nov 2009 12:30

Please register dotConnect for MySQL in the web.config file of your application.
For more information, please refer to http://www.devart.com/dotconnect/mysql/docs/?Deployment.html.
If you encounter any difficulties, feel free to contact us.
Shalex
Devart Team
 
Posts: 7391
Joined: Thu 14 Aug 2008 12:44

Postby Twixies » Tue 17 Nov 2009 18:40

It was just what was needed. I blushed :oops: and completely tear my hair than not to read properly in the help file.
Many thanks for your help. Now is time to test.

Thanks :) support. Problem solved
Twixies
 
Posts: 2
Joined: Tue 17 Nov 2009 08:10


Return to dotConnect for MySQL