lost connection problem -- still happening?

lost connection problem -- still happening?

Postby shutterstock » Fri 15 Jul 2005 17:07

I can't seem to figure out why this is happening...

is there any more information I can get from the MySQLDirect.NET component? I catch the exception - and i get the error code.. and the error message... but i can't figure out why it's happening... doing all the research on these forums and groups.google.com - this is the relevant information..

1) DNS info is correct -and resolves ok both ways.. so there shouldn't be any problems there

2) I'm using Visual Studio .NET 2.0 and MySQLDirect 3.0 (for .NET 2.0).

3) it happens most of the time on my production machine - but it has happened on the development machine.. I'm not sure this is any clue - because it runs for much longer in the production enviornment.

4) the MySQL server.err log (on a linux machine) - doesn't report anything weird.. in fact.. the server never stops running.. and doesn't restart

5) it happens when inserting LOTS of information (thousands of rows) at once.. i tried to do multiple inserts (2-3k rows per statement) .. and increase the query_buffer size.. to the max size (168MB).. but this still doesn't help...

6) I increased the ConnectionTimeout to property to 5 minutes..

any ideas?
shutterstock
 
Posts: 27
Joined: Sat 28 May 2005 20:37

Postby Serious » Mon 18 Jul 2005 13:24

Did you change MySqlComand.CommandTimeout property as i advised you in my previous post?
This exception is likely to be avoided by increasing this property.
Serious
 

Postby shutterstock » Mon 18 Jul 2005 14:34

Ok - this seems to have done it...

I misread that as ConnectionTimeout...

CommandTimeout was right...

Jon
shutterstock
 
Posts: 27
Joined: Sat 28 May 2005 20:37


Return to dotConnect for MySQL