Web application works locally, but config error on upload

Web application works locally, but config error on upload

Postby notken » Mon 27 Oct 2008 14:42

Hi there. My local machine is running this fine, but if I upload (not deploy, just copy) to one of our Web servers I get the following error:

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Exception has been thrown by the target of an invocation.

Source Error:

Line 64:
Line 65: Line 66: type="CoreLab.MySql.Web.Providers.MySqlMembershipProvider"
Line 67: description="MyDirect membership provider"
Line 68: applicationName="GPv3"


Source File: D:\Test sites\Sulis clients\gpv3\web.config Line: 66

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


I've tried removing default membership providers from Machine.config, but it hasn't helped. Sometimes a refresh gets past these lines but generates the same error further down web.config on the role provider info.

I'm really at a loss as to what to try as the error message is so vague. Any help, please? Thanks!
notken
 
Posts: 6
Joined: Mon 27 Oct 2008 13:57

Postby Shalex » Tue 28 Oct 2008 10:08

Please follow this steps:

1) try setting this entry in your D:\Test sites\Sulis clients\gpv3\web.config file file (try setting the full type):

..
/>

2) check registration at GAC or placing in the Bin folder the following run-time assemblies: CoreLab.MySql.dll, CoreLab.Data.dll, CoreLab.MySql.Web.dll and App_Licenses.dll.
Refer to http://www.devart.com/mysqlnet/docs/ , the "Deployment" section

3) refer to http://www.devart.com/mysqlnet/docs/ , the "Using MyDirect .NET" section, the "ASP .NET Provider Model Support" part.
Shalex
Devart Team
 
Posts: 7826
Joined: Thu 14 Aug 2008 12:44

Postby notken » Tue 28 Oct 2008 14:04

Hi there. Thanks for the pointers.

I had an older version of CoreLab in the GAC which another site was using, so I updated the older site to the latest version of CoreLab, removed the old dlls and installed the new ones. I failed to get the runtime license to build from Licences.licx, so couldn't successfully include them in the bin folder, but now that it's all in GAC it seems to be running fine, thanks.
notken
 
Posts: 6
Joined: Mon 27 Oct 2008 13:57


Return to dotConnect for MySQL