Cant deploy site - Configuration Error

Cant deploy site - Configuration Error

Postby robertnzana » Fri 17 Oct 2008 23:58

I created an ASP.NET website using the latest version of MyDirect.NET. All is fine locally.

My licenses.licx file consists of this line:
CoreLab.MySql.MySqlConnection, CoreLab.MySql, Version=4.85.36.0, Culture=neutral, PublicKeyToken=09af7300eec23701

Before I copied all the files to the server I did a "Build Runtime Licenses".

I then uploaded all the source files (including licenses,licx, app_licenses.dll, etc...) to the webserver. Now when I open the website on the internet I get this error. Any ideas why?

Error:

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'CoreLab.Data.Design, Version=4.70.24.0, Culture=neutral, PublicKeyToken=09af7300eec23701' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 98:
Line 99:
Line 100:
Line 101:
Line 102:


Source File: C:\inetpub\wwwroot\mysite\web.config Line: 100

Assembly Load Trace: The following information can be helpful to determine why the assembly 'CoreLab.Data.Design, Version=4.70.24.0, Culture=neutral, PublicKeyToken=09af7300eec23701' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053
Last edited by robertnzana on Mon 20 Oct 2008 13:04, edited 1 time in total.
robertnzana
 
Posts: 23
Joined: Fri 12 Sep 2008 05:07

Postby Shalex » Mon 20 Oct 2008 07:08

Try commenting reference to the CoreLab.Data.Design.dll assembly in your web.config file and notify us on the results.

It is not recommended to use this assembly in web projects.
Shalex
Devart Team
 
Posts: 7780
Joined: Thu 14 Aug 2008 12:44

Postby robertnzana » Mon 20 Oct 2008 12:50

I fixed it by searching my PC for the DLL then copying that one into the bin directory. It seems to fix it. I'm wondering why it wasn't included with the others. Oh well... Thanks.
robertnzana
 
Posts: 23
Joined: Fri 12 Sep 2008 05:07


Return to dotConnect for MySQL