Problem in connection of Mysql5.1 embedded using mydirect.ne

Problem in connection of Mysql5.1 embedded using mydirect.ne

Postby zubair1599 » Tue 30 Sep 2008 09:14

i have licensed version of mydirect.net 4.85.36. i am using ado.net entity framework in my .net applicaiton. mydirect.net works fine when i connect to mysql server. but when i use embedded version of mysql, and when mydirect.net tries to open connection, the application crashes. there is no support available for this problem. can any body guides me.!
zubair1599
 
Posts: 3
Joined: Wed 27 Aug 2008 06:28

Postby Shalex » Thu 02 Oct 2008 08:38

We cannot reproduce the problem.
Please make sure your configuration of MySql Embedded Server is correct. Refer to our documentation ( http://www.devart.com/dotconnect/mysql/docs/ , section "Using MyDirect .NET", part "Using Embedded Server"). Read carefully "Limitations".
We recommend:
1) to create a separate folder for Embedded Server (e.g. c:/servers/embedded/), it must contain the share and data folders - just copy it from server installation folder;
2) to place the libmysqld.dll file to the Windows\System32 folder;
3) to make right configuration in the my.ini file or in the connection string (there is an example in our documentation);
4) to use only one copy of Embedded Server, and before using it make sure that MySql Server doesn't have access to the data of Embedded Server. Only one application may work with the Embedded Server instance at the one moment of time.

If you find any unclear moments in our documentation, please feel free to contact us.
Shalex
Devart Team
 
Posts: 7781
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL