MyDirect bug when using SSH

MyDirect bug when using SSH

Postby Lars » Sun 21 Sep 2008 05:44

I have emailed support three times with this bug report (first email was over a week ago), but have heard nothing back, so I am trying the forum:

There appears to be a bug in MyDirect when using SSH. When inserting many records in a row, it works for the first few hundred records, but then it just "disappears" (i.e. if you are in the debugger and step through the ExecuteNonQuery, it never comes back from there and does not throw an exception nor display any kind of message. Just vanishes. I have tested this from two different development environments (at different locations) as well as against two completely different MySQL servers and databases (one using InnoDB and one using MyISAM). If I do not use SSH, it works perfectly. See below for how to reproduce.

I am using the latest version (4.85.35.0). The previous build (4.85.34.0) had the same issue.

Please look into this ASAP, it is urgent.

Thanks,
Lars

Here is how to reproduce (this ThisDoesNotWork stops after inserting 748 records):

CREATE TABLE `test` (
`ID` INTEGER(11) NOT NULL AUTO_INCREMENT,
`Description` VARCHAR(50) COLLATE latin1_swedish_ci DEFAULT NULL,
PRIMARY KEY (`ID`)
)ENGINE=MyISAM
AUTO_INCREMENT=1 CHARACTER SET 'latin1' COLLATE 'latin1_swedish_ci';

private void ThisDoesNotWork()
{
MySqlConnection myConn = new MySqlConnection("host=191.168.1.10;protocol=SSH;user=joe;password=whatever;database=test");
myConn.SshOptions.User = "joe";
myConn.SshOptions.Password = "whatever";
myConn.SshOptions.Host = "191.168.1.10";
myConn.Open();
for (int i = 0; i < 5000; i++)
{
string sqlString = "INSERT INTO test (Description) VALUES ('Some description of whatever...')";
MySqlCommand myCommand = new MySqlCommand(sqlString, myConn);
myCommand.ExecuteNonQuery();
}
myConn.Close();
}

private void ThisWorks()
{
MySqlConnection myConn = new MySqlConnection("host=191.168.1.10;user=joe;password=whatever;database=test");

myConn.Open();
for (int i = 0; i < 5000; i++)
{
string sqlString = "INSERT INTO test (Description) VALUES ('Some description of whatever...')";
MySqlCommand myCommand = new MySqlCommand(sqlString, myConn);
myCommand.ExecuteNonQuery();
}
myConn.Close();
}
Lars
 
Posts: 7
Joined: Sun 21 Sep 2008 05:38

Postby Shalex » Mon 22 Sep 2008 08:30

We are investigating this problem. You will be notified as soon as possible.
Shalex
Devart Team
 
Posts: 7293
Joined: Thu 14 Aug 2008 12:44

Postby Shalex » Wed 24 Sep 2008 11:48

The problem is fixed. Look forward to the next build that will be available in several days. Please notify us if the problem disappears.
Shalex
Devart Team
 
Posts: 7293
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for MySQL