Build Runtime Licenses with ASP.NET Web Application

Build Runtime Licenses with ASP.NET Web Application

Postby Kris Nobels » Thu 10 Jul 2008 19:59

I Just got a license (great)

But when i try to add it to my project i have a problem. :-(

There already is a topic on this forum on how to add licenses ( http://devart.com/forums/viewtopic.php?t=9041 )

Now I already created a web application and build my DAL with LLBL gen. (So far so good)

Localy everything works fine.

I add the licenses.licx file. But when i right click on it there is no option Build Runtime Licenses ??

Than i created a new project, only this time i select new Web Site inside Visual Studio 2008. (instead off Web application)

Again i add my licenses file.

I right click on it and it works inside Website ! ??

Is it possible to build runtime licenses inside Web Application ?

I would like to have it working inside my web application.

if anyone can help me out :-)

...

Kris
Kris Nobels
 
Posts: 1
Joined: Wed 02 Jul 2008 20:48

Postby AndreyR » Mon 14 Jul 2008 13:05

Hello, Kris.

Please check you have added the 'licenses.licx' file as Embedded Resource.
Then check that your compiled project contains the licenses as a resource. (Run Tools->MySql->License Information. Make sure it contains the following lines "The project has correct licenses.licx file." and "The compiled module has correct license information." )
Ignore the following error: The library has a reference to CoreLab.MySql but cannot check if the library is used by an additional executable." .

Regards, Andrey.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

Postby AndreyR » Thu 17 Jul 2008 10:39

Hello, Kris.

Try copying policy files from %WinDir%\Assembly\GAC_MSIL\Policy.4.xx.CoreLab.xx
to the according folder at the machine you wish to deploy the application on.

That should help.

Regards, Andrey.
AndreyR
Devart Team
 
Posts: 2919
Joined: Mon 07 Jul 2008 13:16

re:

Postby mackkaif » Tue 15 Dec 2009 12:51

thanks for sharing :)
mackkaif
 
Posts: 3
Joined: Mon 30 Nov 2009 14:29

Postby ukanase » Tue 14 Sep 2010 13:49

Hello Kris,

Please share how you included license information in your existing web site project. We are also facing same problem in our application.

Thanks,
Umesh
ukanase
 
Posts: 1
Joined: Tue 14 Sep 2010 13:46

Postby StanislavK » Wed 15 Sep 2010 09:59

ukanase, do you mean that the Build Runtime Licenses option is unavailable for the licenses.licx file? Note that this option is available only for files located in the root folder of the site. Please ensure that licenses.licx is in the root folder.

If the problem persists, please specify the version of dotConnect for MySQL and Visual Studio you are using and, if possible, send us a test project with which the problem can be reproduced.
StanislavK
Devart Team
 
Posts: 1710
Joined: Thu 03 Dec 2009 10:48


Return to dotConnect for MySQL