SSL problem

SSL problem

Postby pheze » Fri 27 Jun 2008 13:50

It says in the documentation that I need to use:
"protocol:SSL" in the connection string.
However, it throws an exception saying that there's an invalid value for Protocol; it says that I need to choose between TCP, MEMORY or PIPE.

However, if I run mysqld with --ssl, there's no error message saying that it is not installed. Furthermore, I can connect to this mysql with SSL by using mysql.exe and have_ssl is YES. I also include path to my certs in the query.. but as I said, it seems that there's a problem with the Protocol part? Weird.

Thanks
pheze
 
Posts: 2
Joined: Fri 27 Jun 2008 13:43

Postby Alexey.mdr » Fri 27 Jun 2008 15:08

Hello,

Could you please specify the version and edition of MyDirect .NET?

Regards,
Alexey.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby pheze » Fri 27 Jun 2008 15:34

I have reinstalled everything from the start.

MySql / openSSL / visual studio, the connector.. really everything.
And, with the same code, it worked.

I don't really know what to think about this, maybe it is something reliated to the certificats or a bug with something reliated to mysql.

I thank you for your help thought.
I would like to be able to say what I have modified to make it works, but as I said, I've just reinstalled everything.
pheze
 
Posts: 2
Joined: Fri 27 Jun 2008 13:43


Return to dotConnect for MySQL