Errors building SQL queries for datadapters

Errors building SQL queries for datadapters

Postby mikeH » Mon 15 Nov 2004 23:47

Hello, When using MyBuilder within MySQLdirect pro 2.3 I get this error when trying to create queries.
"Client does not support authentication protocol requested by server consider upgrading mysql client"

Can someone tell me why this is???


Thanks


Mike H
mikeH
 

Errors building SQL queries for datadapters

Postby mikeH » Mon 15 Nov 2004 23:49

sorry this is with MySQL 4.1...
mikeH
 

Postby Duke » Tue 16 Nov 2004 08:55

Such error happens when your MySQL client library (libmysql.dll) does not support server you are trying to connect.
You can upgrade MySQLDirect to latest version. There are new design-time tools there.
Duke
Devart Team
 
Posts: 476
Joined: Fri 29 Oct 2004 09:25

Errors building SQL queries for datadapters

Postby mikeH » Wed 17 Nov 2004 07:07

Actually I installed 2.7 and the design tools are now missing all together...

:(
mikeH
 

Postby Duke » Wed 17 Nov 2004 08:27

Probably, you are facing the problem described in topic http://crlab.com/forums/viewtopic.php?t=47
We are working on this problem now.
Duke
Devart Team
 
Posts: 476
Joined: Fri 29 Oct 2004 09:25


Return to dotConnect for MySQL