System.FormatException when connecting to 5.0.22 MySQL using MySqlnet 355 pro 2 drivers

System.FormatException when connecting to 5.0.22 MySQL using MySqlnet 355 pro 2 drivers

Postby sumit » Wed 12 Mar 2008 18:44

Hello,

When trying to connect to 5.0.22 MySQL database using MySqlnet 355 pro 2 drivers, we are getting the following exception:

System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at CoreLab.Common.Utils.TryParseInt(String s, Int32& pos)
at CoreLab.MySql.ab.g(String A_0)
at CoreLab.MySql.MySqlInternalConnection.get_ServerVersionNormalized()
at CoreLab.MySql.MySqlConnection.f()
at CoreLab.MySql.MySqlConnection.Open()

Any insights into the problem? The connection string looks like this:

"User Id=xxxx;Password=password;Port=5243;Host=hostname;Database=dbname"

Thanks!
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby sumit » Wed 12 Mar 2008 18:46

Sorry did not mean to post the message twice! Received the following error when tried to post, so went back and posted the message again...

Ran into problems sending Mail. Response: 535 authorization failed (#5.7.0)

DEBUG MODE

Line : 131
File : smtp.php
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Alexey.mdr » Thu 13 Mar 2008 06:35

Sorry, there were some technical problems on the server. I have left one post.
Is the error sporadic?
How did you start to receive it?
What is your OS and IDE?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby sumit » Thu 13 Mar 2008 16:43

Hi Alexey,

The machine where this problem exists, it exists every time. I am not sure about the machine specifics since the problem is happening on one of our customer's machine, but I am pretty sure that the OS is Windows 2003. We have a webex conference with the customer today to try to trouble shoot the problem. I will note the OS and IDE. Is there anything else that you want us to look at on the machine? What else can cause it? Also, this problem exists on only one machine, other machines at customer's end are fine.

Thanks,
Sumit
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Alexey.mdr » Fri 14 Mar 2008 06:47

Please tell as many details about the problem as possible. It'll help us a lot.
Was the user able to connect at any MySQL server at all?
If it is possible, please provide a block of code where the error occurred.
Is the user able to connect to the server via any utility (like MySQL Command Line Client)?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby sumit » Fri 14 Mar 2008 13:21

After looking at customer's system yesterday, we found that his windows user account has very little privileges. No registry write permissions, no permissions to open regedit, etc. The customer will get his permissions thing taken care of and then will try again. If it works, then permissions was the culprit, otherwise, I will update you with more information on the problem. But here is some information:

No, the user was not able to connect to MySQL using the application at any time.
The code block is really simple. The exception occurs at connection.Open();
Yes, the user is able to connect to MySQL using mysql.exe
sumit
 
Posts: 62
Joined: Wed 03 Jan 2007 22:23

Postby Alexey.mdr » Fri 14 Mar 2008 14:35

Probably limited privileges may be the source of the problem.
We are waiting for the news.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for MySQL