Compact Framework 3.5 with Visual Studio 2008

Compact Framework 3.5 with Visual Studio 2008

Postby jasongarrett » Tue 11 Mar 2008 00:07

Hi,

I've just licensed MySQL SQL.NET Mobile 4.50, and installed the following...
mysqlnet450mob2.exe

I have had VS2005 installed previously, but removed. I have VS2008 Professional RTM installed.

Installing mysqlnet450mob2.exe errored with a CreateProcess failed relating to devenv.exe not found. I can see that the \Program Files\CoreLab folder is populated, but when using VS2008, working on a Compact Framework 2.0 or 3.5 project, I could not see the CoreLab components in the ToolBox.

Being adventurous, and have read a large number of forums articles, I have performed the devenv /setup, and devenv /resetskippkgs steps to see if this solved it. No.

The registry key fix suggested in another post already existed and appeared correct, so no issue there.

Choosing 'Add Items' by right clicking on my VS2008 Toolbox, I can browse to C:\Program Files\CoreLab\MyDirect.NET2 Mobile, and select CoreLab.MySql.dll. The components are listed, which I select/check, and click OK. Selecting Show All in the Toolbox, I can see that they are not listed still.

Searching further, I found that additional CoreLab files are installed into C:\Program Files\Microsoft.NET\SDK\CompactFramework\v2.0\WindowsCE.
Using the Toolbox | Add Items option, I browsed to the copy of CoreLab.MySql.dll in this folder, selected it, clicked OK, and magically the components appear in the Toolbox. GREAT!!!

However, I know find that they are only selectable when using a Compact Framework 2.0 Project, and not available when using a 3.5 Project. Are the components only for 2.0? Is there any way I can use them in my 3.5 projects??? as there are features in this newer framework that I want to use.

Regards
Jason
jasongarrett
 
Posts: 3
Joined: Mon 10 Mar 2008 23:54

Postby Alexey.mdr » Tue 11 Mar 2008 14:09

I suppose the first error started causing problems like a snowball.
What OS have you got on the machine?
We do not experience such problems on a PC running under Windows XP SP2.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby jasongarrett » Tue 11 Mar 2008 19:22

I have WinXP SP2.

I'll start from clean in a VMWare VM, and see if I can perform a clean install.
I'll try installing into
a VM with VS2005,
a VM with VS2008,
a VM with VS2005 + VS2008,
and also a VM with VS2005 installed but removed, and VS2008 installed

Jason
jasongarrett
 
Posts: 3
Joined: Mon 10 Mar 2008 23:54

Postby Alexey.mdr » Wed 12 Mar 2008 08:25

Please, let me know if such problems occur again on the VM.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby jasongarrett » Thu 13 Mar 2008 19:56

Okay...

-- VS2005 --
Clean WinXP SP2, with all Automatic Updates performed, but not IE7, and Malicious Software Removal Tools.
Installed VS2005.
Applied VS2005 SP1
Installed ActiveSync 4.5 setup
Installed Windows Mobile 5.0 SDK for Smartphone Installed Windows Mobile 5.0 SDK for Pocket PC Created SmartDevice WM5 Project and verified it built correctly Installed mysqlnet450mob2 Created SmartDevice WM5 Project and verified it built correctly

So far so good.

-- VS2008 --
Clean WinXP SP2, with all Automatic Updates performed, but not IE7, and Malicious Software Removal Tools.
Installed VS2008 (using VS2008ProEdition90dayTrialENUX1435622.iso)
Installed ActiveSync 4.5 setup
Installed Windows Mobile 5.0 SDK for Smartphone Installed Windows Mobile 5.0 SDK for Pocket PC Created SmartDevice WM5 .NET 3.5 Project and verified it built correctly Installed mysqlnet450mob2, but installer failed. ** SEE 01.BMP for error ** Leaving the installer as shown in 01.bmp, I opened the Add/Remove Programs window to allow you to see what other programs are installed. ** SEE 02.BMP & 03.BMP ** I have a VMWare VM currently frozen at this point, so ask as many questions as you like.

Regards
Jason
jasongarrett
 
Posts: 3
Joined: Mon 10 Mar 2008 23:54

Postby Alexey.mdr » Fri 14 Mar 2008 09:00

I have sent you an email.
The problem is reproduced now.
We will fix it in the next build, which is scheduled to be issued in a weeks.
Thank you for the bug report.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for MySQL