Connection Prompt Multiple Times During Use of the Configure your DataSource Wizard

Connection Prompt Multiple Times During Use of the Configure your DataSource Wizard

Postby briankb » Thu 07 Feb 2008 14:12

I get multiple popups during when I use the MyDirect connection tool on my asp.net pages. It slows me down and seems to be a bug since it already has the connection string assigned.

How can I get it to stop?
briankb
 
Posts: 10
Joined: Thu 05 Jul 2007 02:34

Postby Alexey.mdr » Fri 08 Feb 2008 14:08

Could you define more precisely when exactly you get pop-up dialogs?
Describe in a few words what kind of web site you are creating.
What do you expect to see or how would you like to change the existent situation?
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby briankb » Fri 08 Feb 2008 14:47

Software: Visual Studio 2005 OR 2008 Pro
Website: ASP.NET using VB.NET

When: After dragging the MyDirect (MySQL) connector from the toolbox to the page in design mode I do the initial setup for the connection and dataset. That works as expected. However after that anytime the datasource is changed, eventhough it has the connection string embedded, it prompts several times for another connection.

I would like it to stop prompting for a connection when it already has a connection defined.
briankb
 
Posts: 10
Joined: Thu 05 Jul 2007 02:34

Postby Alexey.mdr » Fri 08 Feb 2008 16:45

Try setting Persist Security Info property of the connection to true.
If it doesn't help please send me a small test project to reproduce the problem.
It is desirable to use 'test' schema objects, otherwise include the
definition of your own database objects.
Do not use third party components.
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24


Return to dotConnect for MySQL