License not found BDS 2006 Vista

License not found BDS 2006 Vista

Postby johnp47 » Thu 06 Dec 2007 10:36

Uninstalled trial version then installed mydirect.net v4.25.22.0 pro for .net v1.1. Get a"License not found" error on opening existing project or adding mysqlconnection component to a new asp.net project.

None of the alternative in the help docs seem to make any difference. Are there any particular problems with BDS 2006 or Vista?
johnp47
 
Posts: 5
Joined: Thu 25 Oct 2007 05:57

Postby Serious » Fri 07 Dec 2007 07:13

Try to change your licenses.licx file. Include full assembly version in it:
Code: Select all
CoreLab.MySql.MySqlConnection, CoreLab.MySql, Version=4.25.22.0, Culture=neutral, PublicKeyToken=09af7300eec23701
Serious
 

Postby johnp47 » Thu 13 Dec 2007 11:03

Thanks for the response.

I haven't been able to resolve the problem. Altered the licenses.licx file as above and added to project. Build produces myapp.dll.licenses file in /bin dir identical to one produced using lc.exe. License not found error when adding mysqlconnection component or attempting to connect, license invalid error on running the compiled project in browser.

A couple of questions relating to licenses.
1."Embed as resource", not sure what this involves or how to achieve it.
2. Using .net v1.1 , is app_license.dll required?

Trial installation ran without problems, so I suspect an uninstall issue but I can't find where. I am wondering if a reinstallation of BDS might be an option. Any Ideas?

John
johnp47
 
Posts: 5
Joined: Thu 25 Oct 2007 05:57

Postby Alexey.mdr » Fri 14 Dec 2007 12:35

We have analyzed the problem with licensing and came to conclusion that it is not connected with BDS or Vista.

Take a look in the Web example for Delphi.
Then try to make a new ASP.NET project, create a new connection in design time and open it.
Check if CoreLab.Data.dll and CoreLab.MySql.dll are referenced from the project.
Make sure that the file licenses.licx exists.
Run the project.

If everything works fine, check your current project for referencing wrong (old) assemblies.
Delete all *.dcpil, *.dcuil files from your project.

Otherwise send us, please, a small binary and describe the steps you made to creat it.
Best regards
Alexey.mdr
 
Posts: 729
Joined: Thu 13 Dec 2007 10:24

Postby johnp47 » Sun 16 Dec 2007 04:24

Thanks for the help guys.

Things seem to be working properly now, but not with the original build 4.25.22.0. I downloaded 4.25.23.0 & cleared the files suggested and it worked immediately without any fiddling with the licenses.licx file.

Tried the same on my old xp machine, build 22 didn't work, 23 did, so my guess is a faulty download or build.

Thanks once again.
johnp47
 
Posts: 5
Joined: Thu 25 Oct 2007 05:57


Return to dotConnect for MySQL