License Not Found

License Not Found

Postby tim.heller » Mon 20 Aug 2007 17:39

I have been using this product in a client/server environment with Pro on the client and had your temporary version running on a server... everything worked on the client machine and I could deploy my package to the server just fine until the servers temp expired. Everything was removed from the server and I purchased this site license and re-installed... but still get a "License not found" trying to validate my package on the server.
tim.heller
 
Posts: 3
Joined: Mon 20 Aug 2007 17:36

Postby Alexey » Tue 21 Aug 2007 08:14

Do you write class library (dll), executable application (exe), web project,
web project with dynamically compiled sources?
Do you compile your project in Visual Studio environment or using command line?
When exactly do you receive the error?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby tim.heller » Tue 21 Aug 2007 15:33

This is an SQL Server Integrated Services Package (SSIS). I recieve the error once I deploy this package to the server. Again, nothing has changed in the code or the client machine. Only the server had changed... it had been running your temporary version... it expired, was uninstalled and replaced with Professional Site License.
tim.heller
 
Posts: 3
Joined: Mon 20 Aug 2007 17:36

Postby Alexey » Wed 22 Aug 2007 06:39

How do you deploy it? Please describe in detail so that I could reproduce the problem.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby tim.heller » Wed 22 Aug 2007 15:02

This is configured by simply settin the CreatDeploymentUtility to yes under the Projects Property Page.. After you build (or rebuild) the project it places a file like Programname.SSISDeploymentManifest in the DeploymentOutputPath is typically (bin\Deployment)... double clicking on this walks you through a wizard for targeting the server you wish to deploy to... and also allows you to validate the package... if you select this option and attempt to deploy, it goes through all the steps and attempts to 'validate' each... it's here that I get an error saying the license is not found.
tim.heller
 
Posts: 3
Joined: Mon 20 Aug 2007 17:36

Postby Alexey » Thu 23 Aug 2007 13:18

Thanks for your step-by-step guidance. I could reproduce the problem.
It is a known one. Same thing happens if trying to run the package from the SQL Server Management Studio.
Unfortunately, we cannot support the licensing scheme needed
for this to work properly. You have to write a wrapper library for
MySqlConnection class and add licenses.licx, licenses.config files to it.
In the licenses.config file insert the name of the tool which perform the
deployment (dtsinstall.exe). Such scheme should work without any problem.
P.S. What I can't understand is that how it could work earlier with the trial version...
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for MySQL