unspecified error - packets out of order

unspecified error - packets out of order

Postby m4him » Fri 15 Apr 2005 19:05

I am getting a packet out of order error. I saw the site that said the current update fixes the problem. I updated and it did not fix the problem and when I loaded VS 2003 it said "unspecified error". So I tried to uninstall mysql and it gave the same "unspecified error" but seemed to complete. I then tried to put on a previous version and the installed failed with error 1722 saying the intaller did not finish as expected. I then did a system restore to yesterday and had exactly the same results error making it impossible to reinstall the package.

I reinstalled the current release which did install without an error. When I bring up VS 2003 it gives the "unspecified error" and when I run my project I get the packets out of order error.

So now my entire development system is down. I have users waiting for me to fix the packet error problem but I can not even get the bad update installed.

Please give me a solution as soon as possible.

Kenton Brown
REGISTERED USER since 2003
m4him
 
Posts: 4
Joined: Fri 15 Apr 2005 18:57

Postby Serious » Mon 18 Apr 2005 06:32

Try to reinstall MySQLDirect .NET. Check before that MySQLDirect isn't installed and there are no CoreLab.MySql.dll, CoreLab.MySql.Addin.dll, CoreLab.MySql.Design.dll files in GAC.

To remove MySQLDirect .NET manually you should:
Stop Windows Installer service;
Delete key in the registry
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products
that corresponds to MySQLDirect .NET;
Delete key in the registry
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Assemblies
that corresponds to CoreLab.MySql.dll;
Remove all CoreLab.* assemblies from GAC;
Stop IIS service if you install Web demos virtual directories;
Remove \Program Files\CoreLab\MySQLDirect.NET folder.
After that you can install MySQLDirect .NET again.


Execute the next command and send us corelab.log file: msiexec /i mysqlnet.msi /l*v corelab.log
Serious
 

Postby m4him » Mon 18 Apr 2005 15:19

I tried your solution without success. Even if I install the first version of 2.7 i receive the same error from the dbtools saying unspecified error. I never say that error until I installed the 2.70.4 library
to fix the problem I reinstalled VS 2003 and then installed 2.70.4. BUT I still have the "net packet out of order" error. I created a new post that deals specifically with that issue.
m4him
 
Posts: 4
Joined: Fri 15 Apr 2005 18:57


Return to dotConnect for MySQL