Connection error: System.Net.Sockets.NetworkStream

Connection error: System.Net.Sockets.NetworkStream

Postby DmailOracle » Mon 18 Jun 2007 13:29

Hi,

I'm testing version 4.0.14 of Oradirect.dll Mobile .NET 2, but I'm have a connection problem with the database.
After having opened and closed the connection a few times the following error appears:

TestConnessione.exe
ObjectDisposedException
System.Net.Sockets.NetworkStream

at System.Net.Sockets.NetworkStream.Write()
at CoreLab.Oracle.j.z()
at CoreLab.Oracle.q.b()
at CoreLab.Oracle.a0.b()
at CoreLab.Oracle.d.b()
at CoreLab.Oracle.j.c()
at CoreLab.Oracle.u.d()
at CoreLab.Oracle.at..ctor()
at CoreLab.Oracle.ad.e()
at CoreLab.Common.DbConnectionFactory.k()
at CoreLab.Common.DbConnectionPoolGroup.i()
at CoreLab.Common.DbConnectionPool.a()
at CoreLab.Common.DbConnectionPool.GetObject()
at CoreLab.Common.DbConnectionFactory.j()
at CoreLab.Common.DbConnectionClosed.Open()
at CoreLab.Common.DbConnectionBase.Open()
at CoreLab.Oracle.OracleConnection.Open()
at TestConnessione.Form1.Connetti_Click()
at System.Windows.Forms.Control.OnClick()
at System.Windows.Forms.Button.OnClick()
at System.Windows.Forms.ButtonBase.WnProc()
at System.Windows.Forms.Control._InternalWnProc()
at Microsoft.AGL.Forms.EVL.EnterMainLoop()
at System.Windows.Forms.Application.Run()
at TestConnessione.Form1.Main()


If I reboot the Oracle LISTENER the problem disappears but then after a few connecting attempts the problem reappears.
For the test I'm using .Net 2 (2005), Oracle 8.1.7.0 on Linux Slackware 8.1 and a Pocket PC with Windows mobile 2003.
DmailOracle
 
Posts: 4
Joined: Mon 18 Jun 2007 12:53

Postby Alexey » Tue 19 Jun 2007 06:08

When exactly the error occurs? on Open() or on Close()?
Could you please send me a small test project to reproduce the problem?
Use e-mail address provided in the Readme file.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby DmailOracle » Tue 19 Jun 2007 07:15

I sent an e-mail to info at crlab dot com with a small project.

However the error occurs on Open() after a few attempts.
I tried to set the pooling parameter to false, but the problem doesn't disappear.

Thanks
DmailOracle
 
Posts: 4
Joined: Mon 18 Jun 2007 12:53

Postby Alexey » Tue 19 Jun 2007 08:20

I will investigate your project when it arrives.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Alexey » Thu 21 Jun 2007 09:19

We cannot reproduce the problem on our Oracle servers. Seemingly there is an exception during your connect, and OraDirect .NET treats it wrong way. This leads to the error you get. We are going to fix this in the next build to provide you with appropriate error message in such situations.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby DmailOracle » Thu 21 Jun 2007 10:44

Thank you!
When do you think will be released the new build?
I'd have to test it before purchase.
DmailOracle
 
Posts: 4
Joined: Mon 18 Jun 2007 12:53

Postby Alexey » Thu 21 Jun 2007 11:36

Hopefully, in two weeks.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby DmailOracle » Thu 21 Jun 2007 14:59

You were right!
It was an Oracle error in connection.
Our DBA has solved the problem.
Thanks
DmailOracle
 
Posts: 4
Joined: Mon 18 Jun 2007 12:53

Postby Alexey » Fri 22 Jun 2007 11:46

Well done.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby kalharas » Thu 23 Aug 2007 07:06

hey Dmail...could you tell me how the DBA solved the problem?looks like i am having simmilar problems and could not get over it
kalharas
 
Posts: 11
Joined: Wed 22 Aug 2007 14:20


Return to dotConnect for Oracle