Licensing for asp.net

Licensing for asp.net

Postby cnickel » Wed 25 Oct 2006 00:22

Good evening,

Im kind of in a pickle here.

I am trying to deploy my asp.net web application to a production server, but i am getting an error on my open command. the error is Access is Denied.

I am attributing this to a licensing issue but am unable to figure out what to do.

heres what i have done so far.

1. Added the CoreLab.Oracle line to my licx file and rebuilt the application. this did not work.

2. i have added a Licenses.config file with the line .dll

3. i have tried to manually create the .dll.licenses file. The license compiler indicated that the file was created, but it did nothing to help with the problem once it was deployed.

Any comments or suggestions are greatly appreicated

Thanks in advance.

Chris
cnickel
 
Posts: 4
Joined: Wed 25 Oct 2006 00:15

Postby Paul » Wed 25 Oct 2006 06:42

What exect error message do you have? Licensing code does not have message like "Access is Denied".
What is a version of Visual Studio?
Step 2 is not necessary for ASP .NET applications.
We suppose you compiled App_Licenses.dll using "Build Runtime Licenses" menu in "Solution Explorer" window of Visual Studio 2005 in step 3.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06

Postby cnickel » Wed 01 Nov 2006 15:07

Thanks for your previous reply.

The error message we are seeing is Access is Denied.

and it provides these details...



[ApplicationException: Access is denied.
]
System.Threading.Mutex.CreateMutexNative(Boolean initialState, String name, Boolean& createdNew) +0
System.Threading.Mutex..ctor(Boolean initiallyOwned, String name) +37
CoreLab.Oracle.g.a(String A_0, Int32 A_1, String A_2) +58
CoreLab.Oracle.w.a(String A_0, String A_1, String A_2, String A_3, Int32 A_4, OracleConnectMode A_5) +149
CoreLab.Oracle.OracleInternalConnection..ctor(bb connectionOptions) +453
CoreLab.Oracle.aj.a(DbConnectionOptions A_0, Object A_1, DbConnectionBase A_2) +37
CoreLab.Common.DbConnectionFactory.a(DbConnectionPool A_0, DbConnectionOptions A_1) +37
CoreLab.Common.DbConnectionPool.a() +44
CoreLab.Common.DbConnectionPool.GetObject() +368
CoreLab.Common.DbConnectionFactory.a(DbConnectionBase A_0) +77
CoreLab.Common.DbConnectionClosed.Open(DbConnectionBase outerConnection) +276
CoreLab.Common.DbConnectionBase.Open() +34
CoreLab.Oracle.OracleConnection.Open() +257


We know that the connection string is correct becuase we have used it in other projects.

Any help is appreciated.

Chris
cnickel
 
Posts: 4
Joined: Wed 25 Oct 2006 00:15

Postby Alexey » Thu 02 Nov 2006 07:02

This error has nothing to do with the licensing.
Please provide us with the connection string you use.
What data provider do you use to connect to the Oracle in other projects? Are these projects ASP.NET projects as well?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Alexey » Thu 02 Nov 2006 07:53

Probably, your .NET configuration does not allow to use mutex objects. If so, we found the problem and now we are fixing it.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Deployment of version with fix?

Postby cnickel » Thu 02 Nov 2006 20:41

Hello,

Thanks for your response. would you have an idea when there would be a release of the version with this bug fixed?

currently we have a production site down due to this error.

Thank you,

Chris
cnickel
 
Posts: 4
Joined: Wed 25 Oct 2006 00:15

Postby Alexey » Fri 03 Nov 2006 15:27

This problem is fixed.
Look forward to the next build.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Poonam » Fri 03 Nov 2006 20:51

Alexey wrote:This problem is fixed.
Look forward to the next build.


Do you have an ETA for this next build?

Thank you.
Poonam
 
Posts: 4
Joined: Mon 31 Jul 2006 19:10

patch required ASAP - production server down

Postby plissken » Sun 05 Nov 2006 02:00

Currently have a production server that is down with this same problem.

Is it possible to get a hot fix, or patch of some kind ASAP. Otherwise we will forced to look at a different software package.

Thanks,

Todd
plissken
 
Posts: 1
Joined: Sun 05 Nov 2006 01:49

Postby Alexey » Mon 06 Nov 2006 07:06

The new version of our provider is going to be released in one or two days.
Thanks for your patience.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Fix for mutex problem.

Postby cnickel » Thu 09 Nov 2006 14:17

Alexey,

Thank you for your quick responses, and your quick release of version 3.50.14

This appears to have fixed the problems we were having with the Mutex exception.


Thanks again,

Chris.
cnickel
 
Posts: 4
Joined: Wed 25 Oct 2006 00:15

Postby Alexey » Fri 10 Nov 2006 06:58

Very good.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for Oracle