Cannot find OCI.dll on connect

Cannot find OCI.dll on connect

Postby Giles_Collingwood » Mon 28 Feb 2005 14:12

Hi,

I now get "Cannot find OCI.dll on connect" - this used to work ok on this machine - what have I changed? The OCI.dll is in my path. This is the Info from the Info tab:

Client:
Home: n/a
Version: n/a
Path: not found

Homes:
Default Home: n/a

Server:
(not connected)

When I specify the exact homename from my registry in the connection home property it says that that home does not exist.

I have re-installed Oracle drivers and ORADirect.NET 2.5

Other Oracle apps work ok, including the OraExplorer (without changing the Default Home) !!!

Thanks,

Giles
Giles_Collingwood
 
Posts: 15
Joined: Mon 28 Feb 2005 13:58
Location: London, UK

Postby Oleg » Sat 05 Mar 2005 15:25

You may solve the problem if read this topic
http://www.error-bank.com/microsoft.pub ... hread.aspx
Or send us a value of your environment variable PATH, and registry key
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE.
Oleg
Devart Team
 
Posts: 264
Joined: Thu 28 Oct 2004 13:56

Postby Giles_Collingwood » Sun 06 Mar 2005 20:42

Hi - I tried the solution in the topic - which did not fix it.

Here's my Path

PATH=C:\ora8174\bin;
C:\Program Files\Oracle\jre\1.1.7\bin;
C:\PROGRA~1\PVCS\vm\win32\bin;
C:\PROGRA~1\PVCS\vm\common\bin\win32;
C:\Program Files\Business Objects\BusinessObjects Enterprise 6\bin;
C:\Program Files\Business Objects\BusinessObjects Enterprise 6\bin\orb\bin;
C:\Program Files\Business Objects\BusinessObjects Enterprise 6\bin\orb\asp\5.1\bin;
C:\Program Files\Oracle\jre\1.1.7\bin\;
C:\ora8174\bin\;
C:\WINDOWS\system32;
C:\WINDOWS;
C:\ora8174;
C:\WINDOWS\System32\Wbem;
C:\Program Files\ATI Technologies\ATI Control Panel;
C:\Program Files\Common Files\Adaptec Shared\System;
C:\PROGRA~1\GNU\WINCVS~1.3\CVSNT;
C:\Program Files\Microsoft SQL Server\80\Tools\BINN;
x:\bin;


and here's the registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE]
"ORACLE_HOME_NAME"="OraHome817"
"ORACLE_GROUP_NAME"="Oracle - OraHome817"
"ORACLE_HOME"="C:\ora8174"
"API"="C:\ora8174\dbs"
"inst_loc"="C:\Program Files\Oracle\Inventory"
"OLEDB"="C:\ora8174\oledb\mesg"
"OO4O"="C:\ora8174\oo4o\mesg"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES]
"DEFAULT_HOME"="OraHome817"
"HOME_COUNTER"="1"
"LAST_HOME"="0"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\ID0]
"NAME"="OraHome817"
"PATH"="C:\ora8174"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0]
"ORACLE_HOME_NAME"="OraHome817"
"ID"="0"
"ORACLE_HOME"="C:\ora8174"
"ORACLE_GROUP_NAME"="Oracle - OraHome817"
"NLS_LANG"="ENGLISH_UNITED KINGDOM.WE8ISO8859P1"
"ORACLE_HOME_KEY"="Software\ORACLE\HOME0"
"SQLPATH"="C:\ora8174\dbs"
"MSHELP_TOOLS"="C:\ora8174\MSHELP"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLAP]
"OLAP_HOME"="c:\ofa64\olap"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLAP\Oracle Express Connection Editor]

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLAP\Oracle Express Connection Editor\6.3.2]
@=""

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLAP\Oracle Express Spreadsheet Add-In]

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLAP\Oracle Express Spreadsheet Add-In\6.3.2]
@=""

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OLEDB]
"CacheType"="Memory"
"ChunkSize"="100"
"DistribTX"="1"
"FetchSize"="100"
"OSAuthent"="0"
"PLSQLRSet"="0"
"PwdChgDlg"="1"
"SchRstLng"="10000"
"UserDefFn"="0"
"DisableRetClause"="1"
"TraceCategory"="0"
"TraceFileName"="c:\OraOLEDB.trc"
"TraceLevel"="0"
"TraceOption"="0"

[HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\OO4O]
"CacheBlocks"="20"
"FetchLimit"="100"
"FetchSize"="4096"
"HelpFile"="C:\ora8174\MSHELP\oracleo.hlp"
"PerBlock"="16"
"SliceSize"="256"
"TempFileDirectory"="c:\temp"
"OO4O_HOME"="C:\ora8174\oo4o"

Thanks for your help

Giles
Giles_Collingwood
 
Posts: 15
Joined: Mon 28 Feb 2005 13:58
Location: London, UK


Return to dotConnect for Oracle