Help migrating development from .net 1.1 to 2.0

Help migrating development from .net 1.1 to 2.0

Postby kevinherring » Mon 19 Jun 2006 13:51

We are about to move all our development from 1.1 to 2.0.

The first phase of the migration is to remove 1.1 from all client machines, install 2.0, and to ensure that all our 1.1 compiled programs work on machines with only 2.0 installed.

All our 1.1-compiled programs now work on machines with only a 2.0 runtime installed, except ones using oradirect. Using the 1.1 version of oradirect in a 2.0 environment throws an access denied error when you try to open the connection (as detailed back in December 2005).

Is there any way to make the 1.1 version of 3.20 work in a 2.0 environment so that our software will work with machines with either 1.1 or 2.0 installed?

Many thanks
Kevin
kevinherring
 
Posts: 64
Joined: Wed 04 Jan 2006 15:32

Postby Alexey » Tue 20 Jun 2006 06:03

You should install OraDirect for .NET 2.0.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby kevinherring » Tue 20 Jun 2006 08:00

hmmm, very insightful.

Does OraDirect for .NET 2.0 work with .NET 1.1 as well? Because if it doesnt, then it doesnt really help me much!
kevinherring
 
Posts: 64
Joined: Wed 04 Jan 2006 15:32

Postby Alexey » Tue 20 Jun 2006 08:23

No, OraDirect for .NET 2.0 doesn't work with .NET 1.1. But you can install both OraDirect for .NET 2.0 and OraDirect for .NET 1.1 at the same time and use them.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby kevinherring » Tue 20 Jun 2006 08:28

ok, so if I have both installed at the same time, how will it know which version to use at runtime? is there an example of how to accomplish this in some documentation somewhere?
Thanks for your help
kevin
kevinherring
 
Posts: 64
Joined: Wed 04 Jan 2006 15:32

Postby Alexey » Tue 20 Jun 2006 11:05

You can compile you projects with Oradirect for .NET 1.1 and deploy them on .NET 2.0.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby kevinherring » Tue 20 Jun 2006 11:14

no, I cant.

when I compile my .NET 1.1 project with Oradirect 3.2 for 1.1, and then run it on a mchine with only .NET 2.0 installed, I get an 'Access denied' error as detailed here:
http://crlab.com/forums/viewtopic.php?t=2054

are you saying that it is not the case? Has this been fixed with version 3.50?
kevinherring
 
Posts: 64
Joined: Wed 04 Jan 2006 15:32

Postby Alexey » Tue 20 Jun 2006 11:45

You should deploy it with assembly from the OraDirect for .NET 2.0
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby kevinherring » Tue 20 Jun 2006 12:24

right, I have tried 3.50 for 1.1 and it now works fine on a machine with only .NET 2.0 installed.
Thanks
Kevin
kevinherring
 
Posts: 64
Joined: Wed 04 Jan 2006 15:32


Return to dotConnect for Oracle