Failed to find or load the registered .Net Framework Data Provider

Failed to find or load the registered .Net Framework Data Provider

Postby scott.pedersen » Thu 08 Jun 2006 22:59

Hi,

I have raised a few topics on the forum recently, mostly due to my inexperience with OraDirect, but I thought that the one of the reasons for having OraDirect to is remove some of the tedious hand coding of ADO.NET and provide an alternative means to not having to install the Oracle Client on a workstation.

I haven't had much luck with trying to bind a dataset to a ComboBox to show a selection of data the user can choose.

The steps I have gone through are the following -

1. Create a CoreLab.Oracle.OracleConnection, setting the values to connect to the database - This worked fine.

2. Create a CoreLab.Oracle.OracleDataAdapter, setting the connection, setting the Type to TableDirect and choosing a table. This worked fine and I can preview the data in the table using the Preview Data option in the OracleDataAdapter menu.

3. Create a DataSet instance with the DataSet wizard.

4. I then bind the DataSet to the ComboBox, when I go to preview the data using the ComboBox tasks, I get the error 'Failed to find or load the registered .Net Framework Data Provider'.

Also I have had occasions when I have I haven't encountered this error, and have used the (DataBinding) properties of the ComboBox to set the values for the SelectedItem & SelectedValue. When the program has been run no data appears in the ComboBox.

If I could get some help on this it would be greatly appreciated.

Cheers,

Scott.
scott.pedersen
 
Posts: 21
Joined: Tue 06 Jun 2006 03:14
Location: Auckland, New Zealand

Postby Alexey » Fri 09 Jun 2006 06:22

'Failed to find or load the registered .Net Framework Data Provider'

It seems that you don't have OraDirect .NET in the section of machine.config file
("%\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config").
Please check. Reinstall OraDirect .NET if this is true.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Same error, different context

Postby ryanp » Fri 15 Dec 2006 23:01

I get the same error, but in a different context. When I drag a table from the DbExplorer onto a DataSet, I get the following message:

Some updating commands could not be generated automatically. The database returned the following error: Failed to find or load the registered .Net Framework Data Provider.


A DataTable and TableAdapter are created, but no insert, update, or delete commands are generated.

The same error appears in the TableAdapter Configuration Wizard when generating the INSERT, UPDATE, and DELETE statements. The error does not appear when using the DataSet Wizard. Update statements are generated correctly by the DataSet Wizard.

There is an entry for OraDirect in my machine.config file. I am using OraNet Pro 3.50.14 with Visual Studio 2005 Standard.
ryanp
 
Posts: 3
Joined: Tue 03 Oct 2006 19:48

Postby Alexey » Mon 18 Dec 2006 11:18

What is your hardware architecture (32x or 64x)?
Try to use the latest version of OraDirect .NET from our site.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Failed to find or load the registered .Net Framework Data Provider

Postby scott.pedersen » Mon 15 Oct 2007 02:34

Hi,

I am having the same problem again. This time I am running Visual Studio 2005 on a Virtual PC with Windows 2003.

I have installed CoreLab OraDirect .NET 4.20.22.0 and I am receiving the message "Failed to find or load the registered .Net Framework Data Provider".

I have checked the machine.config and have this entry in the DbProviderFactories section :
type="CoreLab.Oracle.OracleProviderFactory, CoreLab.Oracle, Version=4.20.22.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

Please help, I have deinstalled and reinstalled a few times to see if this fixes the problem to no avail.

Cheers,

Scott.
scott.pedersen
 
Posts: 21
Joined: Tue 06 Jun 2006 03:14
Location: Auckland, New Zealand

Postby Alexey » Tue 16 Oct 2007 13:58

We will investigate this problem.
I'll let you know our progress as soon as possible.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Failed to find or load the registered .Net Framework Data Provider

Postby scott.pedersen » Wed 17 Oct 2007 04:05

Hi Core Lab Team,

I have installed CoreLab OraDirect .NET 4.20.22.0 on Windows XP and it seems to run fine.

It might be an issue with trying to run CoreLab OraDirect .NET 4.20.22.0 on Windows 2003 Server.

Is it supposed to be compatible with Windows 2003 Server?

Cheers,

Scott.
scott.pedersen
 
Posts: 21
Joined: Tue 06 Jun 2006 03:14
Location: Auckland, New Zealand

Postby Alexey » Wed 17 Oct 2007 07:56

Is it supposed to be compatible with Windows 2003 Server?

Yes, of course. I will perform a deep testing on this operating system soon.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Alexey » Fri 19 Oct 2007 11:40

Could you send me your test project with data bindings?
Use e-mail address from the Readme.txt file.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby scott.pedersen » Mon 22 Oct 2007 19:16

I can create a test project, but is there a particular Oracle schema that you would like me to use for it?
scott.pedersen
 
Posts: 21
Joined: Tue 06 Jun 2006 03:14
Location: Auckland, New Zealand

Postby Alexey » Tue 23 Oct 2007 07:14

I prefer scott schema, thanks.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby scott.pedersen » Mon 29 Oct 2007 03:44

Hi Alexey,

I have a project using the scott schema for you to test with, but I am unsure how to upload it.

Can you please let me know the easiest way to do this? I know I have done it before I just can't remember.

Cheers,

Scott.
scott.pedersen
 
Posts: 21
Joined: Tue 06 Jun 2006 03:14
Location: Auckland, New Zealand

Postby Alexey » Mon 29 Oct 2007 08:25

The easiest way is to send the project to the address provided in the Readme.txt file :)
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for Oracle