Can not connect SQLDataSource

Can not connect SQLDataSource

Postby ekarasu » Fri 02 Jun 2006 10:13

Hi,

We could not configure SqlDataSource component for Oracle Database (OraDirect .NET). When we include the User Id in the configuration interface, it warns us with "Unknown connection parameter User Id" message. When we omit the User Id and enter only the password, we can proceed to Test Query phase but it fails at the test giving "ORA-00942: table or view does not exist" warning. We are sure that the table exists. (We are using Visual Studio 2005)

When we use ODBC for datasource everything goes well.
ekarasu
 
Posts: 15
Joined: Wed 01 Feb 2006 05:56

Postby Alexey » Fri 02 Jun 2006 11:31

How do you include the User Id in the configuration interface? Please specify the steps you perform.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby ekarasu » Fri 02 Jun 2006 11:43

We
1- Open aspx design and select SqlDataSource
2- Select the "Configure Data Source" link on SqlDataSource component
3- Click "New Connection" button and see "Add Connection" dialog with Oracle Database (Oradirect.NET) data source.
4- Enter the Connection parameters present on the dialog like:
Server: XE
User Id: Sytem
Password: 123456
Allow Saving Password option leave unchecked
Connect as:SYSDBA
Home leave blank
Direct leave blank

We we test the connection we get the mentioned User Id warning.
ekarasu
 
Posts: 15
Joined: Wed 01 Feb 2006 05:56

Postby Alexey » Tue 06 Jun 2006 13:26

When setting wrong user name one get "ORA-1017: invalid username/password; login denied". Which value of ConnectionString do you see in the Add Connection dialog?
Which version of OraDirect do you have?
If not set user name the connection occur without via another user (maybe using OS Autentification), which may not have rights to view the tables. Which value of ConnectionString do you see in the Add Connection dialog when getting the "Unknown connection parameter User Id" error?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Paul » Thu 14 Dec 2006 09:39

We will fix this problem with Turkish regional settings in the next build
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06


Return to dotConnect for Oracle