OraDirect - Port range limited?

OraDirect - Port range limited?

Postby Daniel Geh » Thu 01 Jun 2006 07:28

Hi,

i just tried the latest version of OraDirect.NET trying to figure out how to use the ASP.NET data providers. I didn't manage to get it working: as soon as I tried to register any of the providers in the Web.config-file (as described in the documentation) the ASP.NET Configuration interface of the IIS stoped working -> Error on the "provider configuration"-page.

I then tried to validate if the connection to the Database is working correctly. I Tried the VS2005-Wizard together with the OraDirect.NET Data Provider and found a (maybe the) problem:

Our Database uses port 20004, the wizard only accepts values <= 10000.
Therfore the connection does not work.

Is this a bug in the Wizard or is OraDirect .NET currently limited to ports <= 10000 (why?).

Thanks in advance
Daniel Geh
Daniel Geh
 

Postby Alexey » Thu 01 Jun 2006 12:27

Error on the "provider configuration"-page.

Please specify the error.
I Tried the VS2005-Wizard together with the OraDirect.NET

What wizard are you talking about?
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43

Postby Daniel Geh » Thu 01 Jun 2006 12:54

Hi,

Please specify the error.


I would have specified the error, but there is no Info available from the IIS Web Configuration interface (the one from the VS2005 build-in iis) apart from "An error was encountered. Please return to the previous page and try again."

What wizard are you talking about?


GridView->Choose Data Source->New Data Source->Database->New Connection->DataSource: "OraDirect .NET Data Provider"

"Test Connection" works with Direct=false, but I'm still getting above error in the "ASP.NET Configuration-"interface when using Direct=false ind Web.config.

I don't see any problems in Web.config:

Code: Select all


 
          name="OracleServices"
      connectionString="User Id=mtdev;password=staubtrocken;Direct=true;Data Source=kdejenr2103.dejen.krz.org;Port=20004;SID=HLT" />
 


 
          userIsOnlineTimeWindow="15">
     
                  name="AspNetOracleMembershipProvider"
          type="CoreLab.Oracle.Web.Providers.OracleMembershipProvider"
          connectionStringName="OracleServices"
          enablePasswordRetrieval="false"
          enablePasswordReset="true"
          requiresQuestionAndAnswer="true"
          requiresUniqueEmail="false"
          passwordFormat="Hashed"
          maxInvalidPasswordAttempts="5"
          passwordAttemptWindow="10" />
     

   

 




Any ideas what I did wrong?

Thanks
Daniel Geh
Daniel Geh
 

solved!

Postby Daniel Geh » Thu 01 Jun 2006 13:31

Hi again,

I found out that trying to access the "security"-page in the ASP.NET Configuration gave me some further information. I'm currently not sure, why it didn't work, but I got the "provider configuration"-page working again by using a different name for my providers.

Now
-> Select a single provider for all site management data
lists does still not show these Providers, but I figured, that I'm able to use Membership- and Role-provider by using
-> Select a different provider for each feature (advanced).

Still, the problem with the Direct-mode and Ports above 10000 still exists, though that may be a MS-Problem.

Thanks
Daniel Geh
Daniel Geh
 

Postby Alexey » Fri 02 Jun 2006 12:37

Please send us your test project to reproduce the problem; include definition of your own database objects. Do not use third party components.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for Oracle