Unicode in OraDirect.Net 3.50.09

Unicode in OraDirect.Net 3.50.09

Postby maurerp » Thu 11 May 2006 14:39

Hi,

i've done some testing with OraDirect.net components and have problems with east asian languages (charactersets).

I use oracle 10g database server and Visual Studio 2005. Wanted to post unicode data into a db table. (see below)

ファッションコーディネート

Unicode attribute in the connection object is set to true. After posting data and query it in a db tool, i can't see the east asian characters (only special characters). I have the problem both in direct mode and oci mode.

When i do exact the save test with the componentes in system.data.oracleclient, everything works fine.

Any ideas?
Regards
Patrick
maurerp
 
Posts: 3
Joined: Thu 11 May 2006 14:28

Postby Paul » Thu 11 May 2006 15:09

What is database charset (SELECT Value FROM nls_database_parameters where PARAMETER='NLS_CHARACTERSET')? What is localization in Windows regional settings? Do you have a problem after INSERT or SELECT operation? Can you see inserted text in database using db tool?
Send us please small demo project to demonstrate the problem and include script to create server objects.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06

Postby maurerp » Fri 12 May 2006 12:35

NLS_CHARACTERSET is "WE8MSWIN1252"
NLS_NCHAR_CHARACTERSET is "AL16UTF16"

Oracle 10g

Regional setting is german. Files for east asian languages are installed.

I've sent you a sample project to support@crlab.com.

We've both problems after insert and select. After posting data (japanese characters) into db we only see special characters using db tool. If we post japanese characters in db over db tool and select via OraDirect.NET, we also see special characters.

Same sample with the built in components in system.data.oraclient works fine.

Regards
Patrick
maurerp
 
Posts: 3
Joined: Thu 11 May 2006 14:28

Postby Alexey » Tue 23 May 2006 07:33

Please send us script to create server objects.
Alexey
 
Posts: 2756
Joined: Mon 13 Mar 2006 07:43


Return to dotConnect for Oracle