Will 9.1 app work on 9.4 server?

Will 9.1 app work on 9.4 server?

Postby michaels23 » Fri 22 Sep 2017 18:00

Our ASP.NET app is built with dotConnect 9.1.111. Will it continue to run properly if the server is updated to 9.4?
michaels23
 
Posts: 2
Joined: Fri 22 Sep 2017 17:23

Re: Will 9.1 app work on 9.4 server?

Postby Shalex » Mon 25 Sep 2017 09:23

You should update references to the Devart.* assemblies in your application. You can do that manually (via *.config, *.csproj, etc) or automatically (via Visual Studio > Tools > Oracle > Upgrade Wizard).
Shalex
Devart Team
 
Posts: 7839
Joined: Thu 14 Aug 2008 12:44

Re: Will 9.1 app work on 9.4 server?

Postby michaels23 » Mon 25 Sep 2017 14:00

We do intend to update our app, but I'm trying to find out what will happen if the (shared) server gets updated before we can release our changes?
michaels23
 
Posts: 2
Joined: Fri 22 Sep 2017 17:23

Re: Will 9.1 app work on 9.4 server?

Postby Shalex » Tue 26 Sep 2017 09:14

You will get the exception "System.IO.FileNotFoundException: Could not load file or assembly 'Devart.Data.Oracle, Version=YOUR_PREVIOUS_VERSION, [...]".

As a workaround, refer to https://docs.microsoft.com/en-us/dotnet/framework/configure-apps/redirect-assembly-versions:
* "Redirecting assembly versions by using publisher policy" -> the Devart publisher policy files are created in GAC by our installation
* "Redirecting assembly versions at the app level" -> you should implement this change manually
Shalex
Devart Team
 
Posts: 7839
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle