Connection Error

Connection Error

Postby blitzkreig » Mon 03 Apr 2017 12:32

Hello,
I am trying to connect from .Net to Oracle using Devart.Data.Oracle and am unable to do so I think its a connection string issue can someone here help me with this.

I get System.Data.EntityException error - {"The underlying provider failed on Open."}
Inner Exception - {"ORA-01017: invalid username/password; logon denied"}

Connection String -
<add name="*****DB" connectionString="metadata=res://*/Model_*****.csdl|res://*/Model_*****.ssdl|res://*/Model_*****.msl;provider=Devart.Data.Oracle;provider connection string=&quot;User Id=*****;Password=*****;Server=DEVServer;Direct=True;Sid=*****DEV;Port=1533;Persist Security Info=True&quot;" providerName="System.Data.EntityClient"/>
<add name="*****DBOralceConnection" connectionString="User Id=*****;Password=*****;Server=DEVServer;Direct=True;Sid=*****DEV;Port=1533;Persist Security Info=True" />

Thanks in advance.
blitzkreig
 
Posts: 3
Joined: Mon 03 Apr 2017 12:21

Re: Connection Error

Postby Pinturiccio » Tue 04 Apr 2017 13:19

Please provide the following information:
1. dotConnect for Oracle version;
2. Oracle Server version;
3. Oracle server bitness (x86 or x64);
4. Which result do you get if you execute the following query against your Oracle Server?
Code: Select all
SELECT USERNAME
        ,PASSWORD_VERSIONS
    FROM DBA_USERS
    WHERE USERNAME = 'your user name in the connection string'
ORDER BY 1, 2;
Pinturiccio
Devart Team
 
Posts: 1982
Joined: Wed 02 Nov 2011 09:44

Re: Connection Error

Postby blitzkreig » Tue 04 Apr 2017 14:27

Thanks for your response and below is the information you asked for-

1. dotConnect for Oracle version;
Devart dotConnect for Oracle Trial Version(9.3.230.0)
2. Oracle Server version;
Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production - dev
3. Oracle server bitness (x86 or x64);
x64
4. Which result do you get if you execute the following query against your Oracle Server?
I get password_versions as 10G 11G 12C
blitzkreig
 
Posts: 3
Joined: Mon 03 Apr 2017 12:21

Re: Connection Error

Postby Pinturiccio » Tue 04 Apr 2017 15:20

Please make sure that you specify valid values for the "User Id" and "Password" parameters in both connection strings. If a user requires sysdba privileges, for example, the sys user, you need to add "connect mode=sysdba" to the connection string.
Pinturiccio
Devart Team
 
Posts: 1982
Joined: Wed 02 Nov 2011 09:44

Re: Connection Error

Postby blitzkreig » Tue 04 Apr 2017 15:47

I have tripled checked the UserID and Password everything is correct. We also created a POC using generic .net application to connect to the server and DB and are able to connect to it.
After some digging through the forums this issue was already reported and some suggestions were made regarding DB setting we tried all listed and still does not resolve.
http://forums.devart.com/viewtopic.php?f=1&t=35082&start=15

Fyi I also tried the connect mode=sysdba; still no luck.
blitzkreig
 
Posts: 3
Joined: Mon 03 Apr 2017 12:21

Re: Connection Error

Postby Pinturiccio » Wed 05 Apr 2017 12:35

The described situation seems to be different from the case, described in the forum topic http://forums.devart.com/viewtopic.php?f=1&t=35082&start=15.

Try to connect with dotConnect for Oracle in the OCI mode. Is the issue reproduced in this case?

Please also try installing dotConnect for Oracle 9.2.205 or an earlier version. dotConnect for Oracle Trial 9.2.205 can be downloaded by the following link: http://devart.com/pub/dcoracle92205.exe. Can you establish a direct mode connection with this version?
Pinturiccio
Devart Team
 
Posts: 1982
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for Oracle