Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby BGrojer » Fri 10 Mar 2017 16:42

When mapping a complex type Property in the latest Version the "ColumnName" is ignored during database creation.

e.g. the mapping

Property(p => p.MyComplexType.MyPropertyId).HasColumnName("MyId").IsRequired();

does not result in a column with name "MyId" in the table instead it creates a tablename MyComplexType_MyPropertyId. During query the "MyId" is used.

The standard Sql Server implementation creates it correctly.
BGrojer
 
Posts: 18
Joined: Thu 19 Sep 2013 12:35

Re: Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby Shalex » Wed 15 Mar 2017 10:48

We have sent a test project to your email. Please modify it for reproducing the issue and send the updated project to us.
Shalex
Devart Team
 
Posts: 7839
Joined: Thu 14 Aug 2008 12:44

Re: Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby BGrojer » Mon 27 Mar 2017 08:20

Thanks for your helps guys. I can confirm there is NO issue with that scenario. (the issue was a derived class that was mapped automatically by EntityFramework (and a missing configuration).
The automatically mapped configuration leaded to issues in Oracle but not SQL Server.

Thanks for your support.
BGrojer
 
Posts: 18
Joined: Thu 19 Sep 2013 12:35

Re: Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby Shalex » Tue 28 Mar 2017 11:22

BGrojer wrote:I can confirm there is NO issue with that scenario.
Thank you for confirming.

BGrojer wrote:the issue was a derived class that was mapped automatically by EntityFramework (and a missing configuration).
The automatically mapped configuration leaded to issues in Oracle but not SQL Server.
Please send us a small test project for reproducing the issue.
Shalex
Devart Team
 
Posts: 7839
Joined: Thu 14 Aug 2008 12:44

Re: Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby bharaniKumar » Tue 18 Apr 2017 05:11

[quote="Shalex wrote:
BGrojer wrote:I can confirm there is NO issue with that scenario.
Thank you for confirming.

BGrojer wrote:the issue was a derived class that was mapped automatically by EntityFramework (and a missing configuration).
The automatically mapped configuration leaded to issues in Oracle but not SQL Server.
Please send us a small test project for reproducing the issue.
BGrojer"]Thanks for your helps guys. I can confirm there is NO issue with that scenario. (the issue was a derived class that was mapped automatically by EntityFramework (and a missing configuration).
The automatically mapped configuration leaded to issues in Oracle but not SQL Server.

Thanks for your support.[/quote]



I have facing same problem........
bharaniKumar
 
Posts: 9
Joined: Tue 07 Mar 2017 13:40

Re: Mapping of Complex Type ignored settings in CodeFirst (EF 6.x)

Postby Shalex » Tue 18 Apr 2017 14:23

bharaniKumar, please send us a small test project for reproducing the issue.
Shalex
Devart Team
 
Posts: 7839
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle