ORA-01017: invalid username/password; logon denied

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Thu 16 Mar 2017 12:58

Edward Hollingsworth wrote:Our developers work for a large, well-known corporation and it's a shame that after believing faithfully in this control from a well-known company after all these years, a product would be put out to the public that totally breaks everything that has worked for many years.

Thank you!


Same feelings... I am using the dotConnect components for 8 years, and in my experience the support gradually becomes worse.
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby Edward Hollingsworth » Thu 16 Mar 2017 17:22

SOLVED! Devart, take note. I'm not seeing in the history for any information on this update to let us know.

The version 9.2.220 requires you to use case sensitive logins! If you run "select username, password_versions from dba_users", it MUST return at least 10G and 11G. The flag SEC_CASE_SENSITIVE_LOGIN must be set to 'True'. So say we were using a password of 'test', we reset the password to itself, 'test' and everything was working.

So do I win the trip to Hawaii?

PS version 9.3.230 is now out, mostly to support VS 2017.

Thanks! :D
Edward Hollingsworth
 
Posts: 10
Joined: Tue 14 Mar 2017 19:22

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Thu 16 Mar 2017 17:56

In my case

Code: Select all
  SELECT USERNAME
        ,PASSWORD_VERSIONS
    FROM DBA_USERS
    WHERE USERNAME LIKE 'RLU%'
ORDER BY 1, 2;


returns
Code: Select all
RLUAPP   10G
RLUMSO   10G
RLUREAD   10G


As per company security policies, sec_case_sensitive_logon has been enabled in all databases.

Code: Select all
sec_case_sensitive_logon             boolean     TRUE


My password is/was already case-sensitive, the username was provided in a lowercase (if it matters).

Any ideas?

Tried both uppercased and loweredcased user id - no luck

Code: Select all
user id=rluapp;password=********;server=sgdxwa01-scan.bns;direct=True;sid=RWHd1;port=1535;persist security info=True
Last edited by motuzko on Thu 16 Mar 2017 18:22, edited 1 time in total.
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby Edward Hollingsworth » Thu 16 Mar 2017 18:01

As stated: it MUST return at least 10G and 11G. It appears some modification are needed. Try resetting the existing password to the same one. If the username's password is "test", simply reset it to "test". That should cover it.

We are using x64 version of Oracle 11G.

Good luck. PS: I wont be responding to this thread any more.
Edward Hollingsworth
 
Posts: 10
Joined: Tue 14 Mar 2017 19:22

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Thu 16 Mar 2017 18:35

Edward Hollingsworth wrote:As stated: it MUST return at least 10G and 11G


Oh, I see - thought it MUST return either 10G or 11G
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Thu 16 Mar 2017 19:22

Confirming for devArt: after resetting the password to the same value (we can afford to do this in DEV environment) the
Code: Select all
  SELECT USERNAME
        ,PASSWORD_VERSIONS
    FROM DBA_USERS
    WHERE USERNAME LIKE 'RLU%'
ORDER BY 1, 2;


returns

Code: Select all
USERNAME                       PASSWORD_VERSIONS
------------------------------ -----------------
RLUAPP                         10G 11G       


After such changes, the connection became possible again.
Now, after we figured out the reason for not connecting, the question is: would it be possible to make the component working when the PASSWORD_VERSIONS returns 10G only? Unfortunately, I have no control over non-development environments.

Best regards,
Phil
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby Edward Hollingsworth » Thu 16 Mar 2017 19:31

I have explained everything in this thread.

Good luck. I am removing the modification email alerts.

Thanks!
Edward Hollingsworth
 
Posts: 10
Joined: Tue 14 Mar 2017 19:22

Re: ORA-01017: invalid username/password; logon denied

Postby Edward Hollingsworth » Thu 16 Mar 2017 19:32

Good luck!
Edward Hollingsworth
 
Posts: 10
Joined: Tue 14 Mar 2017 19:22

Re: ORA-01017: invalid username/password; logon denied

Postby Edward Hollingsworth » Fri 17 Mar 2017 11:38

Phil, regarding your question "the question is: would it be possible to make the component working when the PASSWORD_VERSIONS returns 10G only? Unfortunately, I have no control over non-development environments", you will have to play with the 'SEC_CASE_SENSITIVE_LOGIN' setting as previously described.

Please look over the link about authentication. The
https://docs.oracle.com/database/121/DBSEG/authentication.htm#DBSEG003
Edward Hollingsworth
 
Posts: 10
Joined: Tue 14 Mar 2017 19:22

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Fri 17 Mar 2017 12:41

Thanks again, Edward, but I was addressing devArt. ;)
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby Pinturiccio » Fri 17 Mar 2017 16:50

Thank you for the provided information. We are now working on creating a test environment with a user, who has PASSWORD_VERSIONS equal to 10G only, in order to reproduce and fix the issue. We will post here when we get any results.
Pinturiccio
Devart Team
 
Posts: 1955
Joined: Wed 02 Nov 2011 09:44

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Fri 17 Mar 2017 18:23

Pinturiccio wrote:Thank you for the provided information. We are now working on creating a test environment with a user, who has PASSWORD_VERSIONS equal to 10G only, in order to reproduce and fix the issue. We will post here when we get any results.


Thank you so much!
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby motuzko » Tue 28 Mar 2017 16:31

Pinturiccio wrote:Thank you for the provided information. We are now working on creating a test environment with a user, who has PASSWORD_VERSIONS equal to 10G only, in order to reproduce and fix the issue. We will post here when we get any results.


Is there an ETA?
motuzko
 
Posts: 47
Joined: Tue 08 Sep 2009 18:02

Re: ORA-01017: invalid username/password; logon denied

Postby Pinturiccio » Fri 31 Mar 2017 16:34

We are working on the issue and do our best for reproducing it. We will post here when we get results.
Pinturiccio
Devart Team
 
Posts: 1955
Joined: Wed 02 Nov 2011 09:44

Re: ORA-01017: invalid username/password; logon denied

Postby Joost Van Gansbeke » Wed 12 Apr 2017 12:43

Dear support, any news on the solution? It is rather easy to reproduce I must say? :roll:

Regards,
Joost
Joost Van Gansbeke
 
Posts: 19
Joined: Thu 08 Apr 2010 11:24
Location: Belgium

PreviousNext

Return to dotConnect for Oracle