Error accessing DBLink using OraDirect.net

Error accessing DBLink using OraDirect.net

Postby azagthoth » Fri 10 Mar 2006 05:23

Hi All,

We have a database we need to connect to which contains a DBLink to yet another database. The DBLink itself is fine, and indeed using the OraDirect component we can connect to the database itself.

However, when attempting to access tables over the DBLink we're getting the following error (using the SQL select * from person@xyzlink);

OracleException: ORA-12514: TNS:listener could not resolve SERVICE_NAME given in connect descriptor

(Yes the connection works otherwise). I also tested and received the same error using one of the sample applications.

Any ideas?
azagthoth
 
Posts: 2
Joined: Fri 10 Mar 2006 05:18

Postby Paul » Fri 10 Mar 2006 10:26

Try to execute this query using SQL*Plus.
Please check user and password information in CREATE DATABASE LINK command when you are creating link to database. Try to test it with link to the same database.
Paul
 
Posts: 725
Joined: Thu 28 Oct 2004 14:06

Postby azagthoth » Sat 11 Mar 2006 08:21

Paul,

The query works correctly with SQL PLus, as well as with other providers (we've come from ODP.net).

Any other thoughts? Is oradirect supposed to support the dblink syntax?
azagthoth
 
Posts: 2
Joined: Fri 10 Mar 2006 05:18

Postby Guest » Tue 14 Mar 2006 00:30

Please ignore my above request - we've resolved the issue.

It was our DBA turning off the link!! Very sorry to have wasted your time (and mine!!)
Guest
 


Return to dotConnect for Oracle