The property 'X' on type 'Y' cannot be set because the collection is already set to an EntityCollection

The property 'X' on type 'Y' cannot be set because the collection is already set to an EntityCollection

Postby vinz » Fri 16 Jan 2015 13:11

I developed a database model with dotConnect FOR ORACLE and EF6. I did it with Version 8.4.303 and everything worked properly. I updated to Version 8.4.313 and after that my program no longer works.
I get an error when running : The property 'X' on type 'Y' cannot be set because the collection is already set to an EntityCollection.
All navigation properties of my model do not work but I have changed nothing.
This morning I updated to version 8.4.333 but I still have the same mistakes.

I use a DBCONTEXT with Devart ENTITY MODEL. Are the updates of dotConnect change an element of configuration or functionality ?

Thank you for your help
vinz
 
Posts: 11
Joined: Fri 16 Jan 2015 12:51

Re: The property 'X' on type 'Y' cannot be set because the collection is already set to an EntityCollection

Postby vinz » Fri 16 Jan 2015 14:39

I solved the problem with the new verison V.8.4.333. I have update my model from database with this version and the problem disappear.
So the problem became with V.8.4.313 which is a bad version : burn it !

Thankx for the V8.4.333
vinz
 
Posts: 11
Joined: Fri 16 Jan 2015 12:51

Re: The property 'X' on type 'Y' cannot be set because the collection is already set to an EntityCollection

Postby Shalex » Mon 19 Jan 2015 09:52

We confirm that v8.4.313 generates incorrect code when the ProxyCreationEnabled property of the DbContext template is set to True (default value). The bug is fixed in v8.4.333.
Shalex
Devart Team
 
Posts: 7705
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle