ORA-01403 exception in v5.0.847.0

ORA-01403 exception in v5.0.847.0

Postby Devashish » Mon 25 Aug 2014 15:02

Hi,
I am getting an exception “ORA- 01403 no_data_found”.

I have seen that there is another post on this http://forums.devart.com/viewtopic.php?t=16919 but it does not provide any solution to this issue, it just suggests handling it on your own.

I have written the below code to do this. Does it looks good or is there a standard code to do this or do I have to change any setting to handle it?
Code: Select all
Public Overrides Function ExecuteNonQuery(ByVal command As DbCommand) As Integer
    Try
        Return MyBase.ExecuteNonQuery(command)
    Catch exception As OracleException
        If exception.Code = 1403 Then   
            Return 0
        Else                           
            Throw exception             
        End If                         
    End Try
End Function

I would really appreciate any help.
Regards
Dev
Devashish
 
Posts: 3
Joined: Thu 15 May 2014 07:10

Re: ORA-01403 exception in v5.0.847.0

Postby Pinturiccio » Tue 26 Aug 2014 15:25

The reason of the issue is that your SQL statement in the PL/SQL block does not fetch any data. This error occurs on the server side when executing the query, not on the dotConnect for Oracle side. The server returns the error, and our provider generates the corresponding exception.

Check your SQL query to find out the reason of the error. For more information, please refer to http://www.orafaq.com/wiki/ORA-01403
Pinturiccio
Devart Team
 
Posts: 2021
Joined: Wed 02 Nov 2011 09:44

Re: ORA-01403 exception in v5.0.847.0

Postby Devashish » Wed 27 Aug 2014 13:12

Hi Pinturiccio,

Thanks for your reply,

We are upgrading the application from Devart DotConnect Oracle from v5.0.242.0 to v5.0.847.0.

In the older version (v5.0.242.0) this issue was not present after up-gradation only we started seeing this.
Please note that we have not created any changes in the database.

Please clarify why this issue is not there in the older version and coming in the latest one.

Regards
Devashish
 
Posts: 3
Joined: Thu 15 May 2014 07:10

Re: ORA-01403 exception in v5.0.847.0

Postby sohar » Thu 28 Aug 2014 09:42

This post is very good
sohar
 
Posts: 2
Joined: Thu 28 Aug 2014 09:37

Re: ORA-01403 exception in v5.0.847.0

Postby Pinturiccio » Thu 28 Aug 2014 15:26

Please provide us the following information for reproducing the issue:
We are upgrading the application from Devart DotConnect Oracle from v5.0.242.0 to v5.0.847.0.

1. 5.0.242.0 and v5.0.847.0 are versions of Devart.Data.dll assembly. Please tell us dotConnect for Oracle versions. You can find it in the version of the Devart.Data.Oracle.dll assembly or in Visual Studio: in the Tools menu point to Oracle and then click About dotConnect for Oracle. You will see a dialog box displaying the version of dotConnect for Oracle.

2. Send us a small test project with the corresponding DDL/DML scripts.

3. Please describe the steps that reproduce the issue with your project.
Pinturiccio
Devart Team
 
Posts: 2021
Joined: Wed 02 Nov 2011 09:44

Re: ORA-01403 exception in v5.0.847.0

Postby Devashish » Mon 01 Sep 2014 10:21

Hi Pinturiccio,

1. Here is the version of the Devart.Data.Oracle.dll.
Old: 6.10.141.0
New: 8.1.55.0

2. As for the sample I'll be sharing that with you in some time.

3. The exception is coming when the executed query does not return any value.
I'll be explaining this point in detail with the sample.

Regards,
Dev
Devashish
 
Posts: 3
Joined: Thu 15 May 2014 07:10

Re: ORA-01403 exception in v5.0.847.0

Postby Pinturiccio » Tue 02 Sep 2014 15:04

Devashish wrote:2. As for the sample I'll be sharing that with you in some time.

Thank you, we will wait for your sample.
Pinturiccio
Devart Team
 
Posts: 2021
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for Oracle