Enum and StoredProcedure issue

Enum and StoredProcedure issue

Postby McMlok » Wed 19 Jun 2013 08:26

Hello,

I have entity with property witch is enum defined in model. When I dont use storedprocedures for CRUD operations everything works fine. But when I use storedprocedure for insert, update, delete enum property is set to procedure argument as string name of enum member. Stored procedure argument is int type, table column is int and entity property is enum.

I use dotConnect for Oracle 7.7.257
Oracle 11g
EF 5.0

Thanks
McMlok
 
Posts: 20
Joined: Tue 04 Jun 2013 13:01

Re: Enum and StoredProcedure issue

Postby Shalex » Mon 24 Jun 2013 14:14

Thank you for your report. We have reproduced the issue and are investigating it.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44

Re: Enum and StoredProcedure issue

Postby Shalex » Wed 26 Jun 2013 16:55

McMlok wrote:But when I use storedprocedure for insert, update, delete enum property is set to procedure argument as string name of enum member.

You saw string name of enum member in the (In/Out) Value column of the Parameters windows in dbMonitor, didn't you? This is so because dbMonitor gives a string representation (.ToString()) of parameter's value. But the data sent to the database is a number. This is a designed behaviour.

If you encounter another issue, please specify the exact text of the error you are getting and its call stack.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44

Re: Enum and StoredProcedure issue

Postby McMlok » Thu 27 Jun 2013 11:48

I try it again in 7.7.267 and it works. May be there was problem with parameters order in imported procedure and when I see text i DB monitor I thing tahta probelm is there.

Thank's
McMlok
 
Posts: 20
Joined: Tue 04 Jun 2013 13:01


Return to dotConnect for Oracle