Too many changes causing DomainContext to not save?

Too many changes causing DomainContext to not save?

Postby mattbp55 » Wed 29 May 2013 16:23

I have a Silverlight Business Application that uses a WCF RIA Services LinqToEntitiesDomainService<DatabaseEntities> to perform all of the CRUD operations. Because I have to use Oracle for the database I am using Devart's dotConnect for Oracle.

Silverlight 4, Runtime 5.1.20125.0.

Devart dotConnect for Oracle version 6.60.283.0

I am using a Direct connection in my DatabaseModel.Designer.cs file that is under the DatabaseModel.edml file.

Also, I have the Devart.Data dll, Devart.Data.Oracle dll, and Devart.Data.Oracle.Entity dll "Copy Local" set as "True" in the .Web project.

The problem I am having is that on my development machine I can save as many changes as I want to in any part of my application. However when I deploy my application to my production environment, parts of my application can consistently save up to 500 changes with no problem at all.

Image

While other parts of my application will crash consistently when trying to save on average, more than 60 - 80 changes.

Image

Here is the stack trace that is produced when saving only the few changes and the application crashes.

Image

I have already maxed out the maxAllowedContentLength, maxRequestLength, maxBufferPoolSize, maxReceivedMessageSize, maxStringContentLength, maxArrayLength, and maxItemsInObjectGraph to 2147483647 (Int32.MaxValue). So I don't believe the Web.config is what is causing the problem because I can save around 500 changes at one time.

Also, the timeout is set to 1 minute, however, the SubmitChanges fails instantly with the returned error.

Has any one come across this problem and can provide me some direction as to what is causing this problem?

If any other information is needed to help diagnose the problem, let me know.

Thanks,

Matt
mattbp55
 
Posts: 1
Joined: Wed 29 May 2013 16:14

Re: Too many changes causing DomainContext to not save?

Postby Shalex » Fri 31 May 2013 10:48

1. There are no Devart.* components in your stack trace. Why have you decided that the issue is caused by dotConnect for Oracle?
2. Please try to localize the problem and send us a small test project so that we can reproduce the issue in our environment.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle