Errors executing my application after updating to 7.7

Errors executing my application after updating to 7.7

Postby malea » Fri 19 Apr 2013 08:24

Hello,

I have purchased and installed latest version of dotConnect for Oracle Professional (7.7.224).

Till now, I was using version 5.70 in my project without problems.

After updating to 7.7 version, when I launch my application I obtain two critial errors:

The first one:

"System.Security.VerificationException: Operation could destabilize the runtime".

The code:
Code: Select all
private static IEnumerable<CacheX> GetCacheX()
{
    using (var context = new Context())
    {
        return context.MYTABLE.Select(c => new CacheX
        {
            Code = c.CODE,
            Desc = c.NAME
        }).ToArray();
    }
}


The sencond one:

"base {System.SystemException}: Index was outside of the bounds of the array."

The code:

Code: Select all
var test = context.MYTABLE2.Where(c => c.CODE == "A")
                            .GroupBy(c => new { c.ID, c.NUMBER })
                            .ToArray();



I have looked for information but until now I haven't found a solution.
This code was working perfectly with version 5.70.
Could you help me?

Regards.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Mon 22 Apr 2013 09:41

Thank you for the report. We have reproduced the second issue ("Index was outside of the bounds of the array" exception). We will investigate it and inform you about the results as soon as possible.

As for the first issue ("Operation could destabilize the runtime" exception), we couldn't reproduce it. We are sending you a simple test project to the e-mail address you provided in your forum profile. Please check that the letter is not blocked by your mail filter. Please make changes to it so that the issue could be reproduced and send it back to us or send us your project.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Mon 22 Apr 2013 13:25

Thank you.

Could you resend me the test project? I was having problems with my e-mail account and I have changed it in my profile.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Tue 23 Apr 2013 06:02

We have sent you a sample project again, please check that the letter is not blocked by your mail filter.
Please confirm whether you received it or not.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Tue 23 Apr 2013 06:23

I have found a solution.

If I use "ToArray()" just after where clause, it works. But I don't know where is the problem yet.

For the first error:

Code: Select all
private static IEnumerable<CacheX> GetCacheX()
{
    using (var context = new Context())
    {
        return context.MYTABLE.ToArray().Select(c => new CacheX
        {
            Code = c.CODE,
            Desc = c.NAME
        }).ToArray();
    }
}


And for the second error:

Code: Select all
var test = context.MYTABLE2.Where(c => c.CODE == "A").ToArray()
                            .GroupBy(c => new { c.ID, c.NUMBER })
                            .ToArray();


PD: I have received the test project.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Tue 23 Apr 2013 09:57

Thank you for the additional information.
We still can not reproduce the first problem. Could you please give us the definition of the 'CacheX' class, so that we able to investigate this situation. Or, please, make changes to the sample project that we have sent you so that the issue could be reproduced and send it back to us.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Mon 20 May 2013 05:45

The bug related to the 'Index was outside of the bounds of the array' error when using GroupBy in queries is fixed.
New build of dotConnect for Oracle 7.7.242 is available for download now!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=27136.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Tue 02 Jul 2013 17:23

MariiaI wrote:Thank you for the additional information.
We still can not reproduce the first problem. Could you please give us the definition of the 'CacheX' class, so that we able to investigate this situation. Or, please, make changes to the sample project that we have sent you so that the issue could be reproduced and send it back to us.


Hello,

Sorry for the delay. I have sent a mail with my app to reproduce the first problem, because I cannot reproduce the errors with your test app.

I hope you can help me.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Thu 04 Jul 2013 10:53

Thank you for the sample project. The first issue is still not reproducible on our environment.
Please specify the full stack trace of this exception and please refer to these topics, possibly there is a solution for this issue:
Link1, Link2, Link3, Link4, Link5
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Thu 04 Jul 2013 11:23

Sorry, the first line of the stracktrace was not correct. Now it is correct.

en MaterializeCacheTransportista(MaterializerScope )
en Devart.Data.Linq.Engine.ObjectReader`1.a(T& A_0)
en Devart.Data.Linq.Engine.ObjectReader`1.c()
en System.Linq.Buffer`1..ctor(IEnumerable`1 source)
en System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
en Acceso_a_Datos.Cache.CacheSystem.GetCacheTransportistas() en C:\Users\Pepe\Desktop\GC 2.14.0.4\Acceso a Datos\Cache\CacheSystem.cs:línea 667
Last edited by malea on Tue 09 Jul 2013 10:54, edited 2 times in total.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Fri 05 Jul 2013 11:53

Thank you for the additional information. We are investigating this behaviour. We will inform you about the results as soon as any are available.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Tue 09 Jul 2013 10:46

Sorry, the first line of the stracktrace was not correct. Now it is correct.

I have read the topics you sent me and I have not found a solution.

malea wrote: en MaterializeCacheTransportista(MaterializerScope )
en Devart.Data.Linq.Engine.ObjectReader`1.a(T& A_0)
en Devart.Data.Linq.Engine.ObjectReader`1.c()
en System.Linq.Buffer`1..ctor(IEnumerable`1 source)
en System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
en Acceso_a_Datos.Cache.CacheSystem.GetCacheTransportistas() en C:\Users\Pepe\Desktop\GC 2.14.0.4\Acceso a Datos\Cache\CacheSystem.cs:línea 667
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Wed 10 Jul 2013 09:49

Thank you for the additional information. We have reproduced this issue. We are working on it and we will inform you about the results as soon as any are available.

As a workaround, you could change the definitions of CacheTransportista and CacheProveedor from struct to class or remove {get;set;} from the struct definitions.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby MariiaI » Fri 19 Jul 2013 06:42

The bug related to materializing structs in the "select new" clause is fixed.
New version of dotConnect for Oracle 7.8 is released!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=27556.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17

Re: Errors executing my application after updating to 7.7

Postby malea » Fri 19 Jul 2013 06:59

Thank you for the info.
I'm downloading it.
malea
 
Posts: 33
Joined: Fri 25 Jan 2013 08:25


Return to dotConnect for Oracle