Built-in 'connection timeout' doesn't works

Built-in 'connection timeout' doesn't works

Postby kseen » Thu 18 Apr 2013 09:51

After a many times, trying to find some solution on dead threads (please refer to my previous post here: http://forums.devart.com/viewtopic.php?f=1&t=23419), I found that setting 'Connection timeout=0' should help. It really is. But measured time for fact timeout (then an exception will be raised) is random value. It's 20 seconds, then 2 minutes, then 3 minutes, then again 25 seconds and so on.

Should I implement own custom workaround for that or there is something that I was missed for this issue?

Thanks in advance!
kseen
 
Posts: 9
Joined: Thu 06 Oct 2011 10:16

Re: Built-in 'connection timeout' doesn't works

Postby Shalex » Fri 19 Apr 2013 15:01

kseen wrote:trying to find some solution on dead threads

We have answered you at http://forums.devart.com/viewtopic.php?f=1&t=23419.

kseen wrote:I found that setting 'Connection timeout=0' should help

The Connection Timeout connection string parameter works only in the Direct Mode.
This is an Oracle client which controls connection timeout when the provider connects in the OCI mode.
Shalex
Devart Team
 
Posts: 7530
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle