Upgrading to new versions very painful

Upgrading to new versions very painful

Postby edstaffin » Sun 10 Mar 2013 13:22

Hi,
I am a contractor working at a very large multinational. We have been using DevArt for some time now. However, we find that when a new version of dotConnect comes out, it is very difficult for us to roll it out. It seems that only 1 version of the softare can be installed at a time. This means that have to go into each of my 25+ applications reset references, recompile, retest and redeploy every time a new drop of devart comes out that we want. Please tell me there is a better way!
Thanks ... Ed
edstaffin
 
Posts: 43
Joined: Mon 13 Oct 2008 13:23

Re: Upgrading to new versions very painful

Postby MariiaI » Wed 13 Mar 2013 08:33

It seems that only 1 version of the softare can be installed at a time.

Devart data providers use a common assembly (Devart.Data.dll), so it is necessary to install compatible providers versions. However, it is possible to have different versions of dotConnect for Oracle on your workstation, but there are design time problems in Visual Studio in this case. For more information please refer here http://forums.devart.com/viewtopic.php?t=20149

On the other side, you could set the Specific Version property of the references to our assemblies to False in all your projects. In this case, all Devart assemblies will be resolved with the latest installed version because our installation puts the policy*.Devart.* files in the GAC: http://msdn.microsoft.com/en-us/library/7wd6ex19.aspx.

Also, you can use the Tools > LinqConnect/Oracle > Upgrade Wizard menu to upgrade all references in your project to the newer version of the Devart.* assemblies.
MariiaI
Devart Team
 
Posts: 1472
Joined: Mon 13 Feb 2012 08:17


Return to dotConnect for Oracle