Columns list returned from 'select *' shorter than expected

Columns list returned from 'select *' shorter than expected

Postby ian.mcdavid » Thu 01 Nov 2012 17:58

I am running the light version of this software: Devart.Data.Oracle.dll 6.80.350.0 dotConnect for Oracle. I am also experiencing the same behavior with the oracle .NET data access components.

I am running a select * on a table with ~ 575 columns, most of which are of the "Number" data type. After starting the read OracleDataReader instance's FieldCount property says 289. I tried to use the OracleDataAdapter's fill method with the same command, and the DataTable's column collection count some back with 289. I have also tried the ODAC components from Oracle and I get the exact same results. Can anyone tell me how I can select all 575 columns from the table?

I assume 289 is function of the RowSize property of the reader, which happens to be 7292, and the composition of the table column types. The Fetch size and all other properties on all instances used are defaults.

Please, let me know if I can provide any other information as it is important to me to understand the behavior these components. Thanks.

Update: I have also tried a SQL statement which includes every single column name in the select statement and the same behavior is observed.
ian.mcdavid
 
Posts: 1
Joined: Thu 01 Nov 2012 17:38

Re: Columns list returned from 'select *' shorter than expected

Postby Shalex » Mon 05 Nov 2012 13:02

Please send us the DDL script of your table with 575 columns so that we can reproduce the problem in our environment.
Shalex
Devart Team
 
Posts: 7460
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle