Problem with 7.2.77 that cant add model

Problem with 7.2.77 that cant add model

Postby meysam.savameri » Sat 22 Sep 2012 12:53

i have install Devart dotConnect for Oracle 7.2.77.
but when i add entity model to project getting this error:
Generated model file: Northwind.edmx.
Loading metadata from the database took 00:00:02.8090248.
Generating the model took 00:00:03.2489754.
Added the connection string to the App.Config file.
Writing the .edmx file took 00:00:00.0034826.
Unable to generate the model because of the following exception: 'An error occurred while executing the command definition. See the inner exception for details.
ORA-00942: table or view does not exist
'.
Loading metadata from the database took 00:00:02.3860387.
Generating the model took 00:00:00.9344426.
Added the connection string to the App.Config file.
Writing the .edmx file took 00:00:00.0026788.
meysam.savameri
 
Posts: 6
Joined: Sat 22 Sep 2012 12:45

Re: Problem with 7.2.77 that cant add model

Postby Shalex » Mon 24 Sep 2012 11:02

The current build includes a part of the Oracle Spatial and Entity Framework 5 Spatials functionality which relies on MDSYS.ALL_SDO_GEOM_METADATA without a possibility to turn off this feature. The next build will not depend on this synonym. We will notify you when it is available for download.

As a temporary workaround, please use Entity Developer (*.edml, the Devart Entity Model item).
Shalex
Devart Team
 
Posts: 7781
Joined: Thu 14 Aug 2008 12:44

Re: Problem with 7.2.77 that cant add model

Postby meysam.savameri » Tue 25 Sep 2012 08:19

thank you Shalex.
i already tested in vs2010 but already getting this error.
meysam.savameri
 
Posts: 6
Joined: Sat 22 Sep 2012 12:45

Re: Problem with 7.2.77 that cant add model

Postby Shalex » Tue 25 Sep 2012 13:51

The bug with EDM Wizard/LightSwitch when an access to the objects from the MDSYS schema was required is fixed. We will post here when the corresponding build of dotConnect for Oracle is available for download.
Shalex
Devart Team
 
Posts: 7781
Joined: Thu 14 Aug 2008 12:44

Re: Problem with 7.2.77 that cant add model

Postby Shalex » Thu 04 Oct 2012 15:49

New build of dotConnect for Oracle 7.2.96 is available for download!
It can be downloaded from http://www.devart.com/dotconnect/oracle/download.html (trial version) or from Registered Users' Area (for users with active subscription only).
For more information, please refer to http://forums.devart.com/viewtopic.php?f=1&t=25020.
Shalex
Devart Team
 
Posts: 7781
Joined: Thu 14 Aug 2008 12:44


Return to dotConnect for Oracle