Problem with asp.net validation ORA-00942: table or view doe

Problem with asp.net validation ORA-00942: table or view doe

Postby intrad » Thu 24 May 2012 08:21

Hello,

We are migrating our oracle based solution to your dotCotconnect for Oracle with Direct Mode = True set in the connection string.

With dotCotconnect everything works with the exception of ASP.NET validation. We always used oracle DLLs to connect and login without problem.

The connection string is:
Code: Select all
<add name="DevartOracle" connectionString="Data Source=192.168.0.58;port=1521;sid=XE;User id=USERXX;password=XXXXXX;Unicode=true;Direct=true" providerName="Devart.Data.Oracle"/>


In the provider section of web.config we have this:
Code: Select all
<membership defaultProvider="DevartOracleMembershipProvider">
      <providers>
        <remove name="DevartOracleMembershipProvider" />
        <add description="dotConnect for Oracle membership provider"
          applicationName="/APP" connectionStringName="DevartOracle"
          passwordFormat="Hashed" enablePasswordRetrieval="false" minRequiredPasswordLength="1"
          requiresQuestionAndAnswer="false" minRequiredNonalphanumericCharacters="0"
          name="DevartOracleMembershipProvider" type="Devart.Data.Oracle.Web.Providers.OracleMembershipProvider" />
      </providers>
    </membership>

    <roleManager defaultProvider="DevartOracleRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".ASPROLES">
      <providers>
        <remove name="DevartOracleRoleProvider" />
        <add applicationName="/APP" connectionStringName="DevartOracle"
          description="dotConnect for Oracle role provider" name="DevartOracleRoleProvider"
          type="Devart.Data.Oracle.Web.Providers.OracleRoleProvider" />
      </providers>
    </roleManager>

    <profile defaultProvider="DevartOracleProfileProvider">
        <properties>
            <add name="PersonalCode" type="string"/>
            <add name="Admin" type="integer"/>
            <add name="Company" type="integer"/>
            <add name="PersonalCodeAdmin" type="string"/>
            <add name="ReadO" type="boolean"/>
        </properties>
      <providers>
        <remove name="DevartOracleProfileProvider"/>
        <add name="DevartOracleProfileProvider"
            type="Devart.Data.Oracle.Web.Providers.OracleProfileProvider"
            connectionStringName="DevartOracle"
            description="dotConnect for Oracle profile provider"/>
      </providers>
    </profile>


When we try to do
Code: Select all
Membership.ValidateUser(strUser, strPassword)
in the login form we get this error ORA-00942: table or view does not exist
We observed when we enter in the ASP.NET Configuration from VS2010 when we enter in security we get this error An exception occurred. Please contact your administrator.

If we change to standard oracle library configuration everything works.
We are testing with version 6.80.350 and 7.0.6.

Any ideas?

Kind regards.
intrad
 
Posts: 2
Joined: Fri 05 Oct 2007 14:04

Re: Problem with asp.net validation ORA-00942: table or view

Postby Pinturiccio » Thu 24 May 2012 12:51

intrad wrote:in the login form we get this error ORA-00942: table or view does not exist

Before using ASP.NET providers you have to run the InstallWebTables.sql script on the database you want to use. The script can be found in the \Program Files\Devart\dotConnect\Oracle\ folder.

For more information, please refer to http://www.devart.com/dotconnect/oracle/docs/?AspProviders.html
Pinturiccio
Devart Team
 
Posts: 1953
Joined: Wed 02 Nov 2011 09:44

Re: Problem with asp.net validation ORA-00942: table or view

Postby intrad » Thu 24 May 2012 13:14

Great! it now works, thanks you for your help.
intrad
 
Posts: 2
Joined: Fri 05 Oct 2007 14:04


Return to dotConnect for Oracle