licence problem for asp.net and class libraries

licence problem for asp.net and class libraries

Postby dcoracle600pro » Mon 30 Apr 2012 09:04

Hello!

We use your software with asp.net. As long as we use a single assembly project
everything runs fine. We add the license.licx to our web application, then we compile the licence, publish all on our server and we can run it.

But now we use a class library with the dotConnect access and a web application that references this library. We can start it on our developer pc, but not on our server. We tried all possibilities as you describe in your Licensing document.

The license information dialog shows no errors, only the warning:
"The library has a reference to Devart.Data.Oracle but cannot check if the library is used by an additional executable."

We tried to register our web application in the licenses.config but we are not sure, because it is a web application and no real application. We also created licx files for the web application and the class library.

We also tried it, as described in
http://www.devart.com/dotconnect/oracle/docs/?Deployment.html

Can you please give as a hint what we have to do.


Thanks,

Stefan
dcoracle600pro
 
Posts: 43
Joined: Mon 09 Apr 2012 09:57

Re: licence problem for asp.net and class libraries

Postby Shalex » Tue 01 May 2012 12:12

dcoracle600pro wrote:We tried to register our web application in the licenses.config but we are not sure, because it is a web application and no real application.

Please put the name of the process of your web server (e.g., w3wp.exe) in licenses.config before building the web application.
Shalex
Devart Team
 
Posts: 7780
Joined: Thu 14 Aug 2008 12:44

Re: licence problem for asp.net and class libraries

Postby dcoracle600pro » Wed 02 May 2012 14:34

We tried it with the config file, but we still get the same error.

We work as in your "Compiling License Manually" document described.
For what is the licenses.config? lc.exe ignores the file.

Please tell us, where to put the licx and config filesand how to call lc.exe.

Thank you,
Stefan
dcoracle600pro
 
Posts: 43
Joined: Mon 09 Apr 2012 09:57

Re: licence problem for asp.net and class libraries

Postby Shalex » Thu 03 May 2012 13:05

dcoracle600pro wrote:For what is the licenses.config?

In this file enumerate names of executable files that will work with the class library (which uses the Devart.* classes), every file name on separate line.
dcoracle600pro wrote:lc.exe ignores the file.

Please place lc.exe, licenses.licx, and licenses.config in the same folder and generate the license resource. Notify us about the results.
Shalex
Devart Team
 
Posts: 7780
Joined: Thu 14 Aug 2008 12:44

Re: licence problem for asp.net and class libraries

Postby dcoracle600pro » Fri 04 May 2012 09:04

We did it!

What we had to do was: lc.exe must be in same path as licx file
and follow exactly the steps as discribed by tobiasly in
http://forums.devart.com/viewtopic.php?t=19773
dcoracle600pro
 
Posts: 43
Joined: Mon 09 Apr 2012 09:57

Re: licence problem for asp.net and class libraries

Postby mcinnes01 » Thu 22 Nov 2012 13:30

This is causing me massive issues, windows form apps no probs, ran the licence wizard, deployed, done.

Now I am trying to deploy some ASP.Net apps, I followed the instructions as best I could but when I look at the license wizard it still says:

The project has correct licenses.licx file.
The library has a reference to Devart.Data.Oracle but cannot check if the library is used by an additional executable.

This is my licenses.licx:

Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle, Version=7.2.114.0, Culture=neutral, PublicKeyToken=09af7300eec23701

This is my licenses.config:

DataModel1.edps
DataModel2.edps
DataModel1.csdl
DataModel1.ssdl
DataModel2.csdl
DataModel2.ssdl
DataModel1.edml
DataModel2.edml
web.config
DataModel1.CHRISCSEntities.cs
DataModel1.EMPOS.cs
DataModel1.ORGNA.cs
DataModel1.PSDET.cs
DataModel1.PSLDW.cs
DataModel1.UPZ88.cs
DataModel2.PSDET.cs
DataModel2.TestEntities.cs
AJAX_Interface.cs
BusinessLayer.cs
GenericRepository.cs
UnitOfWork.cs
Devart.Data.Oracle

I just added everything I could find that referenced Devart, I don't know if this is correct or not?

I have no idea what I need to do with the lc.exe I can access it via the command line. Do I need to run anything in cmd line?
Do I need to copy lc.exe to my project files?

Please help I have emailed support a few times but still have no response and I have apps I need to deploy urgently.

PS I use 1-click deploy, .Net 4, IIS 7, 2008R2 and my Dev machine is x64 win7, vs2010 sp1.

Thanks,

Andy
mcinnes01
 
Posts: 19
Joined: Wed 27 Jun 2012 13:55

Re: licence problem for asp.net and class libraries

Postby mcinnes01 » Thu 22 Nov 2012 15:40

I wonder if there is something missing in terms of the .Net Data provider in my web.config?

I am very new to this so perhaps you could comment?

Thanks,

Andy

Below is my config so far:

Code: Select all
<?xml version="1.0"?>
<configuration>
  <configSections>
    <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=4.4.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  </configSections>
  <connectionStrings>
    <add name="CHRISCSEntitiesConnectionString" connectionString="metadata=res://*/DataModel1.csdl|res://*/DataModel1.ssdl|res://*/DataModel1.msl;provider=Devart.Data.Oracle;provider connection string=&quot;User Id=chriscs;Password=chriscs;Server=172.20.50.2;Direct=True;Sid=C21L;Port=1526;Persist Security Info=True&quot;"
      providerName="System.Data.EntityClient" />
    <add name="TestEntitiesConnectionString" connectionString="metadata=res://*/DataModel2.csdl|res://*/DataModel2.ssdl|res://*/DataModel2.msl;provider=Devart.Data.Oracle;provider connection string=&quot;User Id=chriscs;Password=chriscs;Server=172.19.0.71;Home=oraclient11g_home1;Direct=True;Sid=C21T;Port=1526;Persist Security Info=True&quot;"
      providerName="System.Data.EntityClient" />
  </connectionStrings>
  <appSettings>
  <add key="Telerik.Skin" value="Black" />
   
   
  </appSettings>
  <system.web>
    <compilation debug="true" targetFramework="4.0" />
    <pages>
      <controls>
        <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />
      </controls>
    </pages>
    <httpHandlers>
      <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
      <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
      <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
    </httpHandlers>
    <httpModules>
      <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" />
      <add name="RadCompression" type="Telerik.Web.UI.RadCompression" />
    </httpModules>
    <httpRuntime maxRequestLength="96256" executionTimeout="180" />
  </system.web>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules runAllManagedModulesForAllRequests="true">
      <remove name="RadUploadModule" />
      <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" preCondition="integratedMode" />
      <remove name="RadCompression" />
      <add name="RadCompression" type="Telerik.Web.UI.RadCompression" preCondition="integratedMode" />
    </modules>
    <handlers>
      <remove name="ChartImage_axd" />
      <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
      <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_DialogHandler_aspx" />
      <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_RadUploadProgressHandler_ashx" />
      <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode" />
      <remove name="Telerik_Web_UI_WebResource_axd" />
      <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
    </handlers>
    <security>
      <requestFiltering>
        <requestLimits maxAllowedContentLength="98566144" />
      </requestFiltering>
    </security>
  </system.webServer>
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
  </entityFramework>
</configuration>
mcinnes01
 
Posts: 19
Joined: Wed 27 Jun 2012 13:55

Re: licence problem for asp.net and class libraries

Postby Shalex » Fri 23 Nov 2012 09:58

1. Please refer to http://www.devart.com/dotconnect/oracle/docs/Licensing.html#lib ("Class Libraries Support"): you should specify w3wp.exe (the name of the IIS process) in licenses.config because it would be the *.exe which executes the assembly of the web application.

2. Refer to http://www.devart.com/dotconnect/oracle/docs/EF.html#project ("Deploying an Entity Framework Project"): inform your environment about the provider factory existence (add the dotConnect for Oracle entry to the DbProviderFactories section).
Shalex
Devart Team
 
Posts: 7780
Joined: Thu 14 Aug 2008 12:44

Re: licence problem for asp.net and class libraries

Postby kifli » Sun 27 Apr 2014 10:33

After fighting with devart licensing for a while, I wrote a blog post about it. I have a web application with many class library projects and don't want to install devart on neither production nor build servers. Fortunatelly I did it. Details here:
http://coder21.blogspot.cz/2014/04/devart-licensing-hell.html
Hope it helps for somebody.
Gabriel
kifli
 
Posts: 2
Joined: Sun 27 Apr 2014 10:20

Re: licence problem for asp.net and class libraries

Postby Albert » Thu 15 Jan 2015 11:18

kifli wrote:I have a web application with many class library projects and don't want to install devart on neither production nor build servers.

I had the same situation, same problems and same conclusion. And I noticed that my integration tests works without licenses file (although licenses file must be in DAL project) too. But web application doesn't work. It needs licenses file.
BTW, I didn't specify w3wp.exe in licenses.config
Albert
 
Posts: 20
Joined: Fri 06 Dec 2013 06:38

Re: licence problem for asp.net and class libraries

Postby Pinturiccio » Fri 16 Jan 2015 16:29

Albert wrote:I had the same situation, same problems and same conclusion.

Please describe which situation, problems and conclusion do you have.

Albert wrote:But web application doesn't work. It needs licenses file.

Please provide the exception message.
Pinturiccio
Devart Team
 
Posts: 2024
Joined: Wed 02 Nov 2011 09:44

Re: licence problem for asp.net and class libraries

Postby Albert » Tue 03 Feb 2015 11:39

Pinturiccio wrote:Please describe which situation, problems and conclusion do you have...
Please provide the exception message.

I had the same situaltion, that kifli described.
Currently I don't have problems :D . I ended up with generating licenses file for each module, that references to Devart's assemlies regardless of whether they use the Devart's classes directly or not.
Albert
 
Posts: 20
Joined: Fri 06 Dec 2013 06:38

Re: licence problem for asp.net and class libraries

Postby Pinturiccio » Mon 09 Feb 2015 16:22

Glad to hear that the issue is solved.

JIC
Our license validator looks for the valid license in the following way:
*.exe -> FirstCalledClassLibrary.dll -> ... -> LastCalledClassLibrary.dll.
The valid license for *.exe has to be available at any level of this chain: either built in *.exe (licenses.licx), or added to one of the used class libraries (licenses.licx + licenses.config with the name of *.exe).
For more information, refer to http://www.devart.com/dotconnect/oracle/docs/?licensing.html.
Pinturiccio
Devart Team
 
Posts: 2024
Joined: Wed 02 Nov 2011 09:44


Return to dotConnect for Oracle