No connection from Windows7 64 bit ultimate direct mode

No connection from Windows7 64 bit ultimate direct mode

Postby afva » Wed 28 Dec 2011 15:25

Hello,

I can make connections to my Oracle 11.1.6 Database (in direct mode) from XP sp3 32bit and
W7sp1 32bit with the following connectionstring:
connectionString = "User Id=user;Password=passwd;Direct=true;Data Source=192.168.123.25;Sid=DEV;Port=1522;";

However, this connection doesn't work with W7 sp1 64bit ultimate.

Development platform is XP prof SP3 32 bit.
I generated the code in x86 mode.


Our version:
Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Microsoft .NET Framework
Version 4.0.30319 SP1Rel

Installed Version: Professional

Microsoft Office Developer Tools 01018-587-3440683-70814
Microsoft Office Developer Tools

Microsoft Visual Basic 2010 01018-587-3440683-70814
Microsoft Visual Basic 2010

Microsoft Visual C# 2010 01018-587-3440683-70814
Microsoft Visual C# 2010

Microsoft Visual C++ 2010 01018-587-3440683-70814
Microsoft Visual C++ 2010

Microsoft Visual F# 2010 01018-587-3440683-70814
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer 01018-587-3440683-70814
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010 01018-587-3440683-70814
Microsoft Visual Web Developer 2010

Crystal Reports Templates for Microsoft Visual Studio 2010
Crystal Reports Templates for Microsoft Visual Studio 2010

Devart dotConnect for Oracle 6.60.258.0
Devart dotConnect for Oracle
Copyright 2002 - 2011 Devart. All rights reserved.
Web: www.devart.com/dotconnect/oracle
Support: support@devart.com

Devart Entity Developer 4.2.85.0
Devart Entity Developer
Copyright © 2008-2011 Devart. All rights reserved.
Web: www.devart.com/entitydeveloper
Support: support@devart.com

Devart OraDeveloper Tools 2.60
Devart OraDeveloper Tools
Copyright 2004 - 2010 Devart. All rights reserved.
Trial version: 0 of 60 days left.
Web: www.devart.com/dbforge/oracle/tools
Support: www.devart.com/dbforge/oracle/tools/support.html
Ordering: www.devart.com/dbforge/oracle/tools/ordering.html

Do you have any idea?
Thank you,

Extra info:
I tested today on above platform with JDeveloper+JDK7 (32bit and 64bit) in direct mode and both tests were successful.
regards.
afva
 
Posts: 39
Joined: Thu 13 Aug 2009 21:22

Postby dape2801 » Mon 02 Jan 2012 15:46

Hello,
just an idea but can it be that the windows firewall on the W7 64bit is blocking the connection?

We've had that problem. Deactivating the firewall (or allow the connections) was our solution.

Kind regards
Peter
dape2801
 
Posts: 6
Joined: Fri 16 Dec 2011 08:06

Postby GrMikeD » Mon 02 Jan 2012 21:33

Devart DLLs are MSIL binaries and cannot be resolved by x86 programs in 64-bit environments. You should consider compiling as Any-CPU if running in 64-bit Windows is desired.
GrMikeD
 
Posts: 22
Joined: Tue 10 Nov 2009 20:24

Postby afva » Mon 02 Jan 2012 22:00

Peter,

I tested with the firewall off with no result. I tested also with JDeveloper/Java in 32bit and 64bit versions which were both successful.
thx anyway.

GrMikeD,
Can I compile with Any-CPU on a XP prof 32bit SP3, or do I have to move VS and DotConnect first to a W7 64bit platform?

Regards.
afva
 
Posts: 39
Joined: Thu 13 Aug 2009 21:22

Postby GrMikeD » Mon 02 Jan 2012 22:36

afva wrote:Can I compile with Any-CPU on a XP prof 32bit SP3, or do I have to move VS and DotConnect first to a W7 64bit platform?


Sure, just change active platform using Build->Configuration Manager menu in VS. Glad to help.
GrMikeD
 
Posts: 22
Joined: Tue 10 Nov 2009 20:24

Postby afva » Thu 05 Jan 2012 12:10

GrMikeD,


First build VS and Dotconnect on W7 64bit platform and it work for the testapp. Than I checked again with the XP platform and I did what you proposed. And it worked too. Thx for all.

Regards.
afva
 
Posts: 39
Joined: Thu 13 Aug 2009 21:22


Return to dotConnect for Oracle